[toolbox] Disable Inspect Mode when switching tools in Toolbox

RESOLVED FIXED in Firefox 20

Status

defect
P2
normal
RESOLVED FIXED
7 years ago
11 months ago

People

(Reporter: rcampbell, Assigned: paul)

Tracking

unspecified
Firefox 20
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

7 years ago
STR:

1. Open Toolbox via Inspect keyboard shortcut (Cmd-alt-I)
2. Select another tool in the Toolbox Toolbar, e.g., Web Console.

Expected Results:
Highlighter is locked on last hovered item. (Alternately, highlighter could go away)

Actual:
We stay in Inspect mode and the highlighter selection follows mouse in content.
Reporter

Comment 1

7 years ago
Nightly: 20.0a1 (2012-12-03).
Blocks: 816946
Assignee

Comment 2

7 years ago
Indeed, we just hide instead of disabling.
Assignee

Comment 3

7 years ago
Posted patch patch v1Splinter Review
Attachment #690854 - Flags: review?(jwalker)
Assignee

Updated

7 years ago
Priority: -- → P2
Whiteboard: [has-patch]
Assignee

Updated

7 years ago
QA Contact: paul
Assignee: nobody → paul
QA Contact: paul
Assignee

Comment 4

7 years ago
review ping?
Comment on attachment 690854 [details] [diff] [review]
patch v1

Review of attachment 690854 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/devtools/inspector/Highlighter.jsm
@@ +144,5 @@
>          this.hide();
>        } else {
> +        if (!this.locked) {
> +          this.attachMouseListeners();
> +        }

Is this a better way of doing this than adding/removing the listeners/timeouts in show/hide?
Attachment #690854 - Flags: review?(jwalker) → review+
Assignee

Comment 6

7 years ago
(In reply to Joe Walker [:joe_walker] [:jwalker] from comment #5)
> Comment on attachment 690854 [details] [diff] [review]
> patch v1
> 
> Review of attachment 690854 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: browser/devtools/inspector/Highlighter.jsm
> @@ +144,5 @@
> >          this.hide();
> >        } else {
> > +        if (!this.locked) {
> > +          this.attachMouseListeners();
> > +        }
> 
> Is this a better way of doing this than adding/removing the
> listeners/timeouts in show/hide?

Yes. We might want to hide but keep the highlighting mechanism.
Assignee

Updated

7 years ago
Whiteboard: [has-patch] → [land-in-fx-team]
Assignee

Comment 7

7 years ago
https://hg.mozilla.org/integration/fx-team/rev/3f2d435dfe60
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/3f2d435dfe60
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 20
Assignee

Updated

7 years ago
Duplicate of this bug: 825543

Updated

11 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.