can't get Images returned from the FilePicker in Webapps

RESOLVED FIXED in Firefox 19

Status

()

defect
P1
normal
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: wesj, Assigned: wesj)

Tracking

unspecified
Firefox 20
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox19 fixed, firefox20 verified, fennec+)

Details

(Whiteboard: A4A)

Attachments

(1 attachment)

Twitter uses an input to do photo uploads. It works great in Fennec. Doesn't work in Webapps. A little bit of logging shows we get back a null intent in GeckoAppShell.onActivityResult(). Not sure why that would happen for webapps but not for the normal Fennec activity.
Adding Kats in case he has an insight
I can't think of any reason that would be the case off the top of my head; I'd have to go diving in the code to find out.
tracking-fennec: --- → +
Priority: -- → P1
Whiteboard: A4A?
This is a P1 we would like this to work; we should figure this out since it this case also adds to the legitimacy of running apps natively.
OS: Linux → Android
Hardware: x86 → ARM
Whiteboard: A4A? → A4A
the onActivityResult() method is getting RESULT_CANCELED for the resultCode. This is expected if the sub activity can't be launched as a child of the current task. The docs call out that if the activity being launched is singleTask, it will return RESULT_CANCELED. I don't believe that these activities are singleTask, but there might be something about our web apps activity that doesn't allow them to have sub activities.

http://developer.android.com/reference/android/app/Activity.html#startActivityForResult%28android.content.Intent,%20int,%20android.os.Bundle%29
Group: core-security
Group: core-security
Posted patch Patch v1Splinter Review
That made it more obvious what the problem was. Thanks brad. I'm not sure why we chose singleInstance here to begin with, but the only difference is that singleTask can have sub-activities launched in the same task. I don't see any reason to avoid that in webapps....
Assignee: nobody → wjohnston
Attachment #696061 - Flags: review?(blassey.bugs)
I'm a bit nervous that this change will force a manual upgrade by users. I think we're already shipping the WebApps activities in the manifest for beta now.
Attachment #696061 - Flags: review?(blassey.bugs) → review+
Comment on attachment 696061 [details] [diff] [review]
Patch v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Initial webapps landing
User impact if declined: Webapps can't use file pickers
Testing completed (on m-c, etc.): Landed on mc today. Tested locally
Risk to taking this patch (and alternatives if risky): Low risk. Very small change only for webapps. I realize my earlier comment about this potentially requiring a user choice during upgrade was wrong.
String or UUID changes made by this patch: None
Attachment #696061 - Flags: approval-mozilla-beta?
Attachment #696061 - Flags: approval-mozilla-aurora?
Comment on attachment 696061 [details] [diff] [review]
Patch v1

We have already gone to build with our final beta and this is not a blocker for release, hence not approving.

I will be ok to approve this for aurora once we have the patch on m-c.
Attachment #696061 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
https://hg.mozilla.org/mozilla-central/rev/ace356855be2
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20
Attachment #696061 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
I can add a photo to a Tweet successfully on Aurora 20.0a2 2013-01-10 on the HTC Desire Z (Android 2.3.3) from the Twitter web app. However I am unable to add the photo from the Twitter app on Firefox Mobile 19 beta 1. When trying to send a tweet with a picture it fails. Resending the tweet without the picture form draft works. I will marked this as fixed on Firefox 20 and will leave this open to retest on Beta 2
You need to log in before you can comment on or make changes to this bug.