Slow jerky scrolling with 100% CPU usage and unresponsive X server

RESOLVED DUPLICATE of bug 82278

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 82278
17 years ago
16 years ago

People

(Reporter: Stephen Moehle, Assigned: Stuart Parmenter)

Tracking

({perf})

Trunk
mozilla1.1alpha
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
If you load the above page in Mozilla and scroll it up and down using the
scrollbar, the scrolling is slow and jerky.  Also the CPU is driven to 100% and
the X server becomes unresponsive to other programs by which I mean that other
programs appear to freeze and only update themselves infrequently while
scrolling the page in Mozilla.  This is not just a problem of Mozilla taking
100% of the CPU but also of Mozilla hogging or overloading the X server since
normally a program can hog the CPU without causing all other apps to appear to
freeze.

This is a Mozilla-only problem.  The performance of NN4 on the same page is
infinitely better and does not harm the rest of the system.

To reproduce:
1) Run xosview or similar to track CPU usage.
2) Load the URL in Mozilla and scroll up and down.
3) The scrolling in Mozilla is slow and jerkey, and xosview has pretty much
stopped updating its display.
4) Stop scrolling in Mozilla.
5) xosview will start updating itself again, and you can see Mozilla has been
using 100% of the CPU.
6) Go back to step 1 but this time run something like xmanimate as well.  You
will see that xmanimate stops updating completely while scrolling in Mozilla.

Tested with Mozilla trunk build 2001051821 on Linux, though I have been seeing
this for quite some while.
System info: RedHat 7 with XFree86 4.0.1 with NVidia Vanta graphics card and 1
GHz Athlon with 256 MB memory.

Updated

17 years ago
Keywords: perf
~30% CPU with win2k SP2 build 20010519.. (CVS opt) and Athlon1.3Ghz, 512MB RAM

Comment 2

17 years ago
could you try with a newer nightly? I think pav checked in some imglib stuff
that should help.
(Reporter)

Comment 3

17 years ago
With the 2001052606 trunk build, the behavior has not improved any.

Comment 4

17 years ago
not seeing this with my linux cvs pull, but do see some jerkyness in scrolling.
Does turning off images solve this?
(Reporter)

Comment 5

17 years ago
How does one turn off images?  I cannot find it in preferences.

Comment 6

17 years ago
works on linux rpm build 2001052819
(Reporter)

Comment 7

17 years ago
I have found what is giving Mozilla fits.  It is the fact that the images on the
page have widths and heights in the IMG tags that are slighty off forcing
Mozilla to scale the images.  The problem is even worse on
http://mkcdrec.ota.be/project/introduction.html where about half way down the
page, there is a fairly large images that is being scaled to half size.

One thing I have noticed is that the problem occurs only you are scrolling the
image into view.  If it is fully in view or is going out of view, there is no
slow down.  Perhaps that is why others have not seen it.

If I load the pages in NN4, they scroll fine with no problems whatsoever.  In
Opera 5, there is some jerkyness the first time the image is scrolled into view,
 but after that it is fine.

In conclusion, Mozilla has serious performance problems scrolling scaled images
into view that other browsers do not have.

Comment 8

17 years ago
imglib?
Assignee: asa → pavlov
Component: Browser-General → ImageLib
QA Contact: doronr → tpreston
(Assignee)

Updated

17 years ago
Target Milestone: --- → mozilla1.1

Comment 9

17 years ago
Actually, there's major problems with scaling images in linux.  See bug 74313.

Comment 10

17 years ago

*** This bug has been marked as a duplicate of 82278 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.