Last Comment Bug 818164 - Font Issue in FF 17
: Font Issue in FF 17
Status: VERIFIED WORKSFORME
: regression
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: 17 Branch
: x86 Windows 7
: -- normal with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Milan Sreckovic [:milan]
Mentors:
Depends on: 814101
Blocks: 715768
  Show dependency treegraph
 
Reported: 2012-12-04 10:36 PST by Matt Grimes [:Matt_G]
Modified: 2015-03-13 13:55 PDT (History)
41 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified
+
verified
+
verified
verified


Attachments
grayscale AA (8.01 KB, image/png)
2012-12-04 11:49 PST, Serg Iv
no flags Details
gfx.content.azure.enabled = true, smoothed/blurred fonts (309.45 KB, image/png)
2012-12-04 18:33 PST, Aeroxima
no flags Details
gfx.content.azure.enabled = false, fonts as expected (259.60 KB, image/png)
2012-12-04 18:34 PST, Aeroxima
no flags Details

Description Matt Grimes [:Matt_G] 2012-12-04 10:36:54 PST
+++ This bug was initially created as a clone of Bug #814101 +++

Cloning this so we can continue to investigate any remaining issues reported in:

https://support.mozilla.org/en-US/questions/942265

It looks like having smoothing and cleartype disabled is still causing the issue in 17.0.1. Wondering if there is any way to estimate how many of our users have this combination or if there are other factors such as classic mode at play here.
Comment 1 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-12-04 10:56:49 PST
1. Smooth Edges ON + Cleartype ON
> text is anti-aliased

2. Smooth Edges OFF + Cleartype ON
> text is anti-aliased

3. Smooth Edges OFF + Cleartype OFF
> text is not anti-aliased

4. Smooth Edges ON + Cleartype OFF
> text is not anti-aliased

Results from testing on Windows 7 with Firefox 17.0.1. Same results with gfx.content.azure.enabled set to true and false. Same results using the Windows Classic theme.

Maybe I'm misunderstanding the issue but it seems I'm not able to reproduce. I have an NVidia 8600GT GPU (if that matters).
Comment 2 [:Cww] 2012-12-04 11:20:28 PST
shouldn't case 4 be somewhat (grayscale) anti-aliased?
Comment 3 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-12-04 11:30:07 PST
(In reply to [:Cww] from comment #2)
> shouldn't case 4 be somewhat (grayscale) anti-aliased?

I'm not seeing any anti-aliasing in #3 or #4. But maybe my computer does support it? or maybe my eyes are incapable of detecting it.
Comment 4 Serg Iv 2012-12-04 11:49:28 PST
Created attachment 688384 [details]
grayscale AA
Comment 5 Serg Iv 2012-12-04 11:50:08 PST
On my PC the difference is pretty obvious. Look at the attached screenshot (for case 3 and 4). With azure disabled text is not anti-aliased in any case.
Comment 6 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-12-04 11:54:38 PST
Thanks for the screenshot so I can see the issue. However, I'm not able to reproduce this on my machine.
Comment 7 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-12-04 11:55:36 PST
Serg, could you kindly share some more information about your computer? OS version, themes, hardware configuration, etc.
Comment 8 Serg Iv 2012-12-04 12:06:53 PST
Athlon 64 x2, ATI Radeon HD 3850 (driver 8.920.0.0 11-9-2011)
Win 7 x32 Home Basic Russian. Standard Win 7 theme with the desktop composition disabled.

Just tried with the desktop composition enabled and with classic theme - same anti-aliased text.
Comment 9 Serg Iv 2012-12-04 12:40:42 PST
oops, sorry, my win is english, not russian.

more info

desktop composition _enabled_ + smooth _off_ = colored anti-aliasing (shadow, blur) in the FF's tabs
Comment 10 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-12-04 12:48:15 PST
(In reply to Serg Iv from comment #8)
> Athlon 64 x2, ATI Radeon HD 3850 (driver 8.920.0.0 11-9-2011)

Any particular reason you are using a driver that's almost a year out of date? Would you care to try the current WHQL driver version for your graphics card?
http://www2.ati.com/drivers/legacy/12-6/12-6-legacy_vista_win7_32_dd_ccc_whql.exe
Comment 11 Serg Iv 2012-12-04 13:07:58 PST
Yes. For some reason Win 7 doesn't like my graphic card. And updates leads to numerous visual glitches.
That anti-aliased fonts are not really issue for me, because my system alway run with font smooth edges ON. I turned it off just for testing.
Comment 12 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-12-04 13:14:25 PST
I switched over to my ATI GPU and I can't reproduce this there either (same results as comment 1). However, I am using an ATI HD6450 with the current Catalyst 12.10 drivers. I can't reproduce what you are seeing. There must be more to this than just Firefox and Windows preferences.
Comment 13 Serg Iv 2012-12-04 13:24:53 PST
Maybe it's because my Win 7 is "Home Basic"?
From Wikipedia:
...Some Windows Aero options are excluded along with several new features.
Comment 14 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-12-04 13:32:13 PST
(In reply to Serg Iv from comment #13)
> Maybe it's because my Win 7 is "Home Basic"?
> From Wikipedia:
> ...Some Windows Aero options are excluded along with several new features.

Perhaps, however using Windows 7 Basic or Windows Classic themes should reproduce this for me if that was the case; they don't.

Anyway, it's clear I'm making no progress here. I'd like to give someone else a chance at digging deeper here. Can someone please jump in and investigate this further?
Comment 15 Aeroxima 2012-12-04 18:33:35 PST
Created attachment 688553 [details]
gfx.content.azure.enabled = true, smoothed/blurred fonts
Comment 16 Aeroxima 2012-12-04 18:34:31 PST
Created attachment 688554 [details]
gfx.content.azure.enabled = false, fonts as expected
Comment 17 Aeroxima 2012-12-04 18:37:58 PST
ClearType: Off
Font Smoothing in Win7: Off

I have this in 17.0.1, but it's not an issue in the 18 Beta.  I thought that meant it was taken care of?
Comment 18 Paul Silaghi, QA [:pauly] 2012-12-05 02:46:01 PST
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #1)
> 1. Smooth Edges ON + Cleartype ON
> > text is anti-aliased
> 
> 2. Smooth Edges OFF + Cleartype ON
> > text is anti-aliased
> 
> 3. Smooth Edges OFF + Cleartype OFF
> > text is not anti-aliased
> 
> 4. Smooth Edges ON + Cleartype OFF
> > text is not anti-aliased

I can see the issue (step 3 - text is anti-aliased with Smooth Edges OFF + Cleartype OFF) on FF 17.0.1 using the Magnifier Tool (colored borders, best seen in the tab title).
This is not reproducible with gfx.content.azure.enabled=false.
Also not reproducible on FF 18b2.
Comment 19 Jonathan Kew (:jfkthame) 2012-12-05 03:13:16 PST
Right - that's the remaining problem in 17.0.1.

As per bug 814101 comment 86, the small prefs patch we took in 17.0.1 fixed the problem for users with ClearType OFF but font smoothing still ON, but did not fix it for those with both options OFF.

The larger azure patch that was landed for FF 18/19/20 fixed the issue for both cases.

-If- there's going to be a 17.0.2 release at some point, I think we could consider uplifting the main azure patch from bug 814101, now that it's had a bit of "bake time" on trunk/aurora/beta, and AFAIK is working fine with no reported issues. Otherwise, affected users (i.e. those who want -no- font smoothing, not even grayscale) should either move to FF18 beta or disable azure as a workaround until FF18 final is released.
Comment 20 R2KFoto 2013-01-08 11:55:08 PST
With FF18 it is still broken.
Comment 21 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2013-01-08 11:58:01 PST
(In reply to R2KFoto from comment #20)
> With FF18 it is still broken.

Please be more specific. Are you seeing specifically what is called out in comment 18 and 19? If so that is expected (at least for now).
Comment 22 R2KFoto 2013-01-08 12:57:44 PST
OK, im a clear type off user.
This is "my" Bug 703625. Something has changed in FF18 Final?
Comment 23 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2013-01-08 13:05:30 PST
Jonathan, could you please help clarify what was actually fixed for Firefox 18 and what remains to be fixed in a future Firefox release?
Comment 24 Jonathan Kew (:jfkthame) 2013-01-08 13:43:58 PST
It's not clear to me exactly what people are seeing. It would be helpful if those still experiencing problems in Firefox 18 could provide:

(a) their settings for font smoothing, both the Smooth Edges of Screen Fonts option found in the System / Advanced Settings / Performance Options panel, and ClearType, which is enabled/disabled using the ClearType Text Tuner (accessed through the Adjust ClearType Text option in the Display control panel);

(b) the Graphics section of about:support;

(c) a screenshot showing the problematic text rendering.
Comment 25 Paul Silaghi, QA [:pauly] 2013-01-10 05:27:04 PST
I've double checked comment 18. Everything looks ok in FF 18 release, 19b1, Win 7 x64.
Comment 26 a.bauer 2013-01-10 13:50:52 PST
In FF 17 and 17.01 the text was clear only when I disabled "gfx.content.azure" in "about:config". 
Now, after updating to FF 18.0 the text is sharp always.

It doesn't matter aynmore  if I enable or disable  the azure setting.

So it seems to be fixed finally. Thank you !!!
Comment 27 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2013-01-10 13:54:20 PST
Thank you a.bauer.

Jonathan, can we just call this fixed and get users to file bugs for specific follow-up issues?
Comment 28 R2KFoto 2013-01-10 22:58:44 PST
I will make a test with a new installation. And I need to reset my "gfx." parameters. Sorry guys i'm busy.
Comment 29 R2KFoto 2013-01-12 05:33:20 PST
A fresh installation of FF18 shows no problems. It turns out that the Addon "Anti-Aliasing Tuner" is problematic. OK the Fonts issues are gone and so there is no need for that Addon anymore.
Comment 30 Adrian 2013-01-14 14:31:05 PST
I still have some problems in FF18 unless I set gfx.direct2d.disabled=true

http://www.planetcoding-server.net/misc/ff-font-ok.png - azure off, direct2d off
http://www.planetcoding-server.net/misc/ff-font-ugly.png - azure off, direct2d on
Comment 31 Paul Silaghi, QA [:pauly] 2013-01-14 14:34:38 PST
I cannot reproduce, as I already said in comment 25. Did you try with a new profile? See comment 29.
Comment 32 Adrian 2013-01-14 14:39:26 PST
just tested - no difference.
Comment 33 Jonathan Kew (:jfkthame) 2013-01-15 00:39:48 PST
(In reply to Adrian from comment #30)
> I still have some problems in FF18 unless I set gfx.direct2d.disabled=true
> 
> http://www.planetcoding-server.net/misc/ff-font-ok.png - azure off, direct2d
> off
> http://www.planetcoding-server.net/misc/ff-font-ugly.png - azure off,
> direct2d on

Why are you turning off azure? As I understand it, that was a workaround for problems in FF17, but should no longer be necessary in 18; bug 814101 specifically aimed to fix non-cleartype rendering in azure.
Comment 34 Adrian 2013-01-15 12:07:12 PST
Azure on/off doesn't really change anything anyway. I tried it because I read in another bug here that it being enabled was the cause for the problem for some other people.
Comment 35 Paul Silaghi, QA [:pauly] 2013-02-27 04:33:47 PST
While testing some plugins blocking, I've noticed a strange font issue:
1. Start Firefox with a new profile
2. In about:config find extensions.blocklist.url and change addons.mozilla.org to addons-dev.allizom.org
3. Force a blocklist ping by evaluating the following code in Error Console:
Components.classes["@mozilla.org/extensions/blocklist;1"].getService(Components.interfaces.nsITimerCallback).notify(null);
4. Close the Error Console
5. Look very carefully at the about:config letters in the location bar while clicking once in the FF window
AR: Suddenly the text is no longer anti-aliased.
FF 20b1, 21.0a2 (2013-02-26), 22.0a1 (2013-02-26) Win 7 x64
Comment 36 Virtual_ManPL [:Virtual] - (ni? me) 2015-01-18 05:02:39 PST
Can you still reproduce the issue with latest version with clean new fresh profile without any addons and plugins?

Note You need to log in before you can comment on or make changes to this bug.