JSCustomObjectBuilder.cpp fails to build with clang 3.1 on Linux

RESOLVED FIXED in mozilla20

Status

()

Core
Gecko Profiler
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: gw280, Assigned: gw280)

Tracking

unspecified
mozilla20
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

/home/george/dev/mozilla-central-2/tools/profiler/JSCustomObjectBuilder.cpp:193:10: error: expected a
      class or namespace
  return PLDHashOperator::PL_DHASH_NEXT;
         ^
/home/george/dev/mozilla-central-2/tools/profiler/JSCustomObjectBuilder.cpp:225:10: error: expected a
      class or namespace
  return PLDHashOperator::PL_DHASH_NEXT;
         ^
2 errors generated.
Created attachment 688478 [details] [diff] [review]
clang fix

Don't prefix PL_DHASH_NEXT.
Attachment #688478 - Flags: review?(bgirard)
Attachment #688478 - Flags: review?(bgirard) → review+
ty ehsan
Duplicate of this bug: 818381

Comment 5

6 years ago
https://hg.mozilla.org/mozilla-central/rev/3658addc5872
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
You need to log in before you can comment on or make changes to this bug.