Closed Bug 818492 Opened 9 years ago Closed 9 years ago

When panning vertically there should be no horizontal movement possible

Categories

(Firefox OS Graveyard :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

(blocking-basecamp:-)

RESOLVED WONTFIX
blocking-basecamp -

People

(Reporter: st3fan, Unassigned)

Details

(Keywords: b2g-testdriver, unagi)

STR:

1) Open any page (it is not page dependend)
2) Zoom in by either two-finger-pinch or double tap
3) Pan vertically

Expected:

The pannning is locked to vertical movement. Horizontal movement is not possible.

Actual:

Panning is completely 'freestyle' and just follows your finger in any direction.


Firefox on Android Nightly does this correct. I'm not sure when it was added though. Can we backport it? I think it is good for usability. All mobile browsers currently do this.
Component: Gaia::Browser → General
This is axis locking, not implemented on purpose.
blocking-basecamp: ? → -
Sorry, this sucks but is by design.  Ping me privately for details.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.