frame displays document based on initial src attribute after resize [frame]

VERIFIED DUPLICATE of bug 48422

Status

()

Core
DOM: Core & HTML
P3
normal
VERIFIED DUPLICATE of bug 48422
17 years ago
10 years ago

People

(Reporter: Hans Aikema, Assigned: Alexandru Savulov)

Tracking

({testcase})

Trunk
mozilla1.1alpha
x86
Windows 2000
testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
BuildID:    2001051804

When resizing a frame in javascript by updating the frameset's cols attribute 
the document that was initially in the frame (as specified in the frameset 
document by its src attribute) is loaded instead of the document that was 
visible in the frame at the moment of resizing.
Updating the frame's src attribute manually in the onLoad event resolves this 
problem, but in my opinion this update is the Mozilla's responsibility instead 
of the webmaster's.
The page at http://home.zonnet.nl/speedsk8/mozilla/framebug.html refers to two 
examples, one of the actual problem and one with the work-around active.

Reproducible: Always
Steps to Reproduce:
1. Load http://home.zonnet.nl/speedsk8/mozilla/framebug1-1.html
2. Play with hide/unhide as you like
3. Go to the second page (link in frameset)
4. click on hide/unhide

Actual Results:  After step 4 the page frame contains the initial document 
(http://home.zonnet.nl/speedsk8/mozilla/framebug1-2.html)

Expected Results:  After step 4 the page frame contains the document you changed 
to (http://home.zonnet.nl/speedsk8/mozilla/framebug1-3.html)

Comment 1

17 years ago
Updating QA contact to Shivakiran Tummala.
QA Contact: desale → stummala

Comment 2

17 years ago
Confirmed with build 2001060308 win2k. The document refered in the src attribute
of the frame is loaded instead of the current document.
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Over to pollmann.
Assignee: jst → pollmann
Bulk reassigning form bugs to Alex
Assignee: pollmann → alexsavulov
(Assignee)

Updated

17 years ago
Summary: frame displays document based on initial src attribute after resize → frame displays document based on initial src attribute after resize [frame]

Comment 5

17 years ago
happens on mac release 0.9.5 (build 2001101117) as well.

does anybody have a workaround hack? alexandru, do you have an estimate when you
will have some time to look at this bug?

Comment 6

17 years ago
oops, too fast. this bug is probably a dupe of bug 69347, which is probably a
dupe of bug 48422, and most probably also related to bug 63980, which should be
marked as a dupe of bug 48422 or bug 69347.

with all this confusion, there is only one solution - fix it ;-)

btw, i'm not allowed to mark this bug as a duplicate.
(Assignee)

Updated

17 years ago
Blocks: 48422
(Assignee)

Updated

17 years ago
Blocks: 69347
(Assignee)

Updated

17 years ago
Blocks: 63980
(Assignee)

Comment 7

17 years ago
i added the dependencies be cause the bugs are not really dups so we don't want
to lose them.

setting milestone
Target Milestone: --- → mozilla1.1

Comment 8

16 years ago
nominating bug for nsbeta1
Keywords: nsbeta1, testcase
Priority: -- → P3
nsbeta1-

*** This bug has been marked as a duplicate of 48422 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Keywords: nsbeta1 → nsbeta1-
Resolution: --- → DUPLICATE

Comment 10

16 years ago
verified dupe
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: stummala → general
You need to log in before you can comment on or make changes to this bug.