Closed Bug 819120 Opened 9 years ago Closed 9 years ago

Google Instant Doesn't Work When DOM STORAGE Is Disabled

Categories

(Firefox :: General, defect)

17 Branch
x86_64
All
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: dli0ivu+wmwzp0, Unassigned)

Details

Attachments

(1 file)

Attached image screenshot.PNG
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

I used Firefox to open Google (https://www.google.com) as normal. I typed "firefox" into the search box. The drop down menu showed the word "firefox" as well as other choices. I pressed Enter.


Actual results:

The page would not load. I also tried pressing the blue "search" button and the results on the drop down menu. Nothing worked.

The same problem also happens no matter WHAT I type into the search box. I am just using "firefox" as an example.

I used the Web Console to look at the problem. A screenshot is attached. The GET requests seemed to be fine, but then I got a strange "HTTP/1.1 204 No Content" error. That seems to be the problem, but I don't know what it means.

I have another PC (Windows XP, Firefox 17.0.1) that has the exact same problem. Google worked fine on both PCs several days ago. I have tried regular Google (http://www.google.com) and the same thing happened. If I go to the Google settings page and turn off "Google Instant", everything works, but without the "Instant" feature.

If I refresh the empty Google page, my results are displayed as normal.


Expected results:

The Google results should have loaded after I pressed Enter or pressed the search button. Also, I should add that IE8 and IE9 worked fine... the Instant results actually loaded.

I also tried using my 10.5.8 Macintosh, with Firefox 16.0.2. The exact same problem happened.

I should also add that I tried using Firefox's Safe Mode. It did not work. I have tried disabling hardware acceleration and enabling the referrer (I disabled it). Nothing worked.
Oh, I'm using Firefox 17.0.1 (latest).

If this is a Google problem (not mine) tell me. There's no reason why my 2 PCs and Mac don't work.
Component: Untriaged → General
Fixed... went into about:config and turned on DOM storage. Everything's back to normal.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
Seems that its a Google problem... see the link.

https://support.mozilla.org/en-US/questions/943705

Changing it back to UNCOMFIRMED since I can't guarantee its not a bug.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
OS: Windows 7 → All
I'm running Ubuntu 12.04 and FF 17.0.1, and ran into the exact same issue.  When testing with other browser--no issue.  

My DOM storage was also disabled and was resolved by following this post.  

FF was recently updated and the issue began immediately.  

I'm glad I found this since I couldn't find the answer on the net.  Thank you!
Yes it's true Google Instant searching is fixed by going into about:config and changing dom.storage.enabled to true, but this isn't a valid solution.  My grandmother shouldn't be expected to figure this out in order to search Google using Firefox.  Google is the Internet for many people, so I hope this bug is prioritised accordingly.  

I've cleared web cache and cookies.  Disabling Javascript allows non-Instant searches to function.
I can confirm that this is happening for me too, since upgrading to Firefox 17.0.1 on Windows XP.

Setting dom.storage.enabled to true works around the problem.
Reproducible on Linux x86_64/32 with Firefox 17.0.1. No issues with v17.0.
I have the same issue with Firefox 17.0.1 and OS X 10.6.8.  Changing the dom.storage either way doesn't fix it.
@sjc... try installing Portable Firefox and see if Google still works. Since its portable, it wont mess up your pc in any way... reply back and see what happens :D

@mr_pink37@live.de... well Firefox 16 doesn't work for me, so I'm not too sure about 17.

@stonecircle... most likely your grandma didnt adjust the dom.storage.enabled setting, unless she is a technical user. The default setting is enabled.

Non-instant searches take away much of the "fun" of Google... so i guess ive lost some of my internet anonymity to make Google work. Im pretty sure its their fault... Google my problem and take a look at some other posts.

It seems to be Google's fault for now... screw them. :( They sacrifice our anonymity for their new "Instant" service.
You can turn Google instant off completely... but people like us who actually CARE about our privacy like to delete our cookies once a week. Pointless. :(
Summary: Google Instant Doesn't Work → Google Instant Doesn't Work When DOM STORAGE Is Disabled
Is there anything that indicates this is a Firefox bug?

Sounds to me like it's simply a bug on Google's side (ie, something in their code breaks when dom storage isn't actually available, instead of falling back to a non-Instant search).
So is there a way to ask Google to fix it? It's getting pretty annoying...
Ok guys... im using Firefox 18.0.1 now with DOM Storage off. Google instant works perfectly. I think Firefox 18 fixed this bug. :D

If it doesnt work for you after upgrading post here.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.