Closed Bug 819190 Opened 7 years ago Closed 7 years ago

Animated persona stops working after browser restart (or after previewing another persona)

Categories

(Firefox :: Theme, defect)

defect
Not set

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox20 - ---

People

(Reporter: sidrabbit, Unassigned)

References

()

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121206 Firefox/20.0
Build ID: 20121206030737

Steps to reproduce:

1. Install animated persona from https://addons.mozilla.org/firefox/addon/mlp-friendship-is-magic-rai/
2. Restart browser. Or try and preview some other persona.


Actual results:

Animation of installed persona stops. You can reactivate animation by switching persona off and on again in Add-on Manager.


Expected results:

Animation of installed persona should never stop.
Last good nightly: 2012-09-23
First bad nightly: 2012-09-24
The regression range: hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9d285bedbc1f&tochange=b2867d82dcad
Component: Untriaged → Theme
Keywords: regression
Tim: Could this be a regression from bug 650968 ?
Yes, that change is intentional. Animated personas are the worst in terms of performance. We need to automatically convert existing personas to be static (if that's possible) and don't allow new animated ones to be created.

See also bug 729656.
Blocks: 650968, 729656
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows 7 → All
Hardware: x86_64 → All
Can we fix this so animated personas are static always and not just after a restart?
Do I understand you people correctly, that someone has intentionally sabotaged the performance of animated personas as part of a plot to ultimately destroy all animated personas and then ban them from Firefox??  Please tell me this is a sick joke and not really what's going on!  There are a lot of persona users as well as designers who have invested a lot of time creating animated personas for everyone's enjoyment (and to Mozilla's benefit).  Why would you want to deprive these Firefox users of the ability to enjoy yet another way to customize their browser experience, just because some programmers are overly obsessed with how many milliseconds of browser performance someone might lose when choosing to run their browser they way THEY choose to?

Nobody is forcing anyone to use animated personas, and they can be designed to have mimimal impact on system resources, even if many often do not (a number of mine were designed with this in mind).  I challenge your statement about "We need to automatically convert existing personas to be static...".  Who needs that?  And why?  Is this a personal feeling or is there some overriding concern for all Firefox users?  As a persona designer and volunteer worker, I am already highly perturbed to find out about this serious misadventure that Mozilla has apparently undertaken.  I suggest you stop and reconsider this course of action and its impact on the popularity of Firefox, don't take the easy way out, and repair this damage so that those who enjoy animated personas can continue to do so, even if you don't.  Doctors shouldn't play God, and programmers shouldn't either.  Give people what they want, not what you think they need or what's convenient for programmers.
I completely agree with BrianZ.
I assure you that that the presence of animated themes still are for many people a reason to choose Firefox as own browser instead of others. Indeed, if the programmers were serious, long since had to create the "animated" in categories.
Dont miss you in pursuing the functionality at any cost to the detriment of the pleasure and beauty!
If there is a performance issue, it's better to investigate and fix the issue, instead of removing the feature where it's more noticeable.

Otherwise it's kinda like putting a duct tape over "check engine" light...
No-one sabotaged anything. Personas were causing startup performance and memory problems because, per spec, they're required to be absurdly large in order to support most screen sizes. The workaround for that was to crop the images to the screen size and cache them for the next startup. This breaks animated personas, since only one frame is cached.

The three viable ways to deal with this are to crop each frame for the cached image, which would help some of the memory and startup issues, to skip the caching for animated personas, which wouldn't, and to remove support for animated personas entirely, rather than having them work until a restart. Since I'm not in the position of having to implement any of the above, I don't have a strong opinion on which is best, but I think that we need something better than half-broken support.
Tim - could we disable this perf win in the case of animated personas?
I've found a workaround. Install Personas Shuffler extension (https://addons.mozilla.org/firefox/addon/personas-shuffler/) and if you have only one persona installed it will be automatically retriggered after each startup, so in fact the animation never stops.

Also I'd like to add my voice for saving animated personas as they are - animated, not static. All this animation may seem girly frou-frou nonsense to the experienced users like you developer guys. But for average home user it's just another eye candy. Let us have our candies, performance isn't everything that matters.
(In reply to Alex Keybl [:akeybl] from comment #9)
> Tim - could we disable this perf win in the case of animated personas?

We can't distinguish between animated and non-animated personas because they have exactly the same structure (two images) but for animated personas it's an animated GIF or PNG instead of a static one. Animated personas are a big foot gun and lead to a constant CPU load of around +40%. They slow down any UI animations and operations we have.
> Animated personas lead to a constant CPU load of around +40%. 
> They slow down any UI animations and operations we have.

It shouldn't happen on modern systems.

Anyone tried to profile where CPU spends most of that time?
I think the performance implications detailed in bug 729656 along with the relatively low desirability of a feature like this in general implies WONTFIX. I know there are people who love their animated themes, and I'm sorry they will be disappointed, but it's not a feature with enough demand for us to actively try to support, given the other issues.

I filed bug 821011 on removing the inconsistent behavior where animated personas work while previewing.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
One thing I forgot to add: it's probably not overly difficult to create an add-on that would enable animated personas while undoing the performance wins of bug 650968. This is not a tradeoff we are willing to make in Firefox, but for some users who are really attached to animated personas, that may be a good alternative. I can help advise anyone interested in writing such an add-on.
Right! Why Mozilla does not solve the problem of animated themes by an add on, as it did in many other occasions ... giving the users to choose democratically?
(In reply to candelora from comment #15)
> Right! Why Mozilla does not solve the problem of animated themes by an add
> on, as it did in many other occasions ... giving the users to choose
> democratically?

Comment #10 has a workaround with an add-on that currently works. Once bug 821011 is resolved, another add-on could be created to activate animated personas again.
Animated personas have been around for years, so why are you guys just now finding fault with them and making speed concerns an issue? It doesn't appear to be an issue for those who want to use them. Cropping and caching regular personas seems like a silly idea to me, and again, hasn't been a problem in the past, so what has changed? All I can say is your actions to cripple personas seems poorly planned and poorly thought out, not to mention lazy. It's easy for you to say an add-on could be created, but if that's true, why don't you create it first before destroying what has been a fun and novel feature for persona users. So much for integrating personas into Firefox. First their name was stolen, and now their functionality. Good luck with whatever you have left.
(In reply to BrianZ from comment #17)
> Animated personas have been around for years, so why are you guys just now
> finding fault with them and making speed concerns an issue? It doesn't
> appear to be an issue for those who want to use them.

We know that users perceive Firefox as slow, particularly when loading. It's not obvious at all for most users what the causes behind this are, they just see Firefox taking several seconds (sometimes minutes!) to load.

Load time is the accumulation of profile load, add-ons, Personas, and other factors. We determined that personas could be a significant factor in load time and fixed the problem. Animated personas not working were an unfortunate consequence of this. However, they are also bad for performance, not only at startup but also during the whole browsing session. How serious this problem is, I don't know. However, it does give us a good reason to prefer disabling the feature rather than fix it.

If there were someone willing to fix the cropping code so that it supports animated personas, and we can confirm their performance is good, I don't see why that wouldn't be accepted.

> It's easy for you to say an add-on could be created, but if that's
> true, why don't you create it first before destroying what has been a fun
> and novel feature for persona users.

Because we can't write that add-on until we know what we need to work around. The add-on code depends on how the bug is fixed.
Duplicate of this bug: 1170568
Duplicate of this bug: 1482616
You need to log in before you can comment on or make changes to this bug.