Need a Policy & Mechanism for Audio Competing & Control (Patch-0 follow-up)

RESOLVED FIXED in Firefox 18

Status

defect
P1
normal
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: airpingu, Assigned: airpingu)

Tracking

unspecified
B2G C2 (20nov-10dec)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+, firefox18 fixed, firefox19 fixed, firefox20 fixed, b2g18 fixed)

Details

Attachments

(1 attachment)

No description provided.
This is absolutely a bb+ because it blocks bug 805333 which is a P1 bb+.
blocking-basecamp: --- → ?
Posted patch PatchSplinter Review
.concat() does not change the existing arrays, but returns a new array, containing the values of the joined arrays.
Attachment #689624 - Flags: review?(jonas)
Hi Jonas,

Thanks for your super quick review!

May I have your bb+ so that we can make the check-in process simpler? Or should I ask another check-in approval for aurora/beta? I'm fine with that too. :)
blocking-basecamp: ? → +
Thanks Gene. Good catch.
(In reply to Gene Lian [:gene] from comment #3)
> Hi Jonas,
> 
> Thanks for your super quick review!
> 
> May I have your bb+ so that we can make the check-in process simpler? Or
> should I ask another check-in approval for aurora/beta? I'm fine with that
> too. :)

Please uplift this remaining audio policy work today.
Target Milestone: --- → B2G C2 (20nov-10dec)
https://hg.mozilla.org/mozilla-central/rev/c6970a82a686
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Although this fix is trivial and should have no harm at all but I still receive some e-mails:

  Talos Regression Trace Malloc MaxHeap increase 0.xxx%

I guess maybe using

  array.push.apply(...)

instead of

  array = array.concat(...)

would help because the former won't create a new array on heap?
Gene: I suspect that's just random noise. It seems very unlikely that this bug would have performance implications.
Whiteboard: [status-b2g18:fixed]
Whiteboard: [status-b2g18:fixed]
You need to log in before you can comment on or make changes to this bug.