crash in nsIContent::GetPrimaryFrame, called from mozilla::a11y::TextAttrsMgr::GetAttributes

RESOLVED FIXED in mozilla30

Status

()

--
critical
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: MarcoZ, Assigned: yzen)

Tracking

({crash})

Trunk
mozilla30
x86
Windows 7
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug][mentor=trev.saunders@gmail.com][lang=c++][tbird crash], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
This bug was filed from the Socorro interface and is 
report bp-1a663c9b-4797-43a3-9c0c-961c82121207 .
============================================================= 

I encountered this crash once today when starting a new article on my WordPress blog, but it doesn't happen reliably. Filing it just in case it reveals something obvious. Might also be related to problems Trevor is encountering with enhancing text attribute tests.

Updated

6 years ago
OS: Windows NT → Windows 7
It seems somehow we have a HyperTextAccessible for something that isn't a element, Alex any idea how that's possible?  How do you eel about an assert that doesn't happen?
(In reply to Trevor Saunders (:tbsaunde) from comment #1)
> It seems somehow we have a HyperTextAccessible for something that isn't a
> element, Alex any idea how that's possible?  How do you eel about an assert
> that doesn't happen?

I don't see alternatives.
Whiteboard: [good first bug][mentor=trev.saunders@gmail.com][lang=c++]
Marco could you try and reproduce with this build? https://tbpl.mozilla.org/?tree=Try&rev=22a25d1c1879
(Reporter)

Comment 4

6 years ago
Trevor, I never saw the bug again unfortunately. So reproducing it may become a real challenge. :)
(Reporter)

Comment 5

6 years ago
A community remember just reported on Twitter that (s)he was seeing crashes, and when I received report IDs, found that this is the same bug I was seeing. The IDs are:
bp-d422654c-bf81-47e7-a9f3-887ca2130326
bp-05bd58fe-2a34-4a2e-a2b8-ec9842130326
Duplicate of this bug: 857340

Updated

5 years ago
Whiteboard: [good first bug][mentor=trev.saunders@gmail.com][lang=c++] → [good first bug][mentor=trev.saunders@gmail.com][lang=c++][tbird crash]

Updated

5 years ago
Crash Signature: [@ nsIContent::GetPrimaryFrame()] → [@ nsIContent::GetPrimaryFrame()] [@ mozilla::a11y::TextAttrsMgr::GetAttributes(nsIPersistentProperties*, int*, int*) ]

Comment 7

5 years ago
I am not able to reproduce this bug in latest build, please send me scenario in which case this bug is produceable. and also let me steps to reproduce this bug.

Updated

5 years ago
Assignee: nobody → riteshnpatel1994
(Reporter)

Comment 8

5 years ago
Had another of those  crashes after ages. I was answering a Facebook friend request, and the dialog where I was asked whether I wanted to confirm or delete had just gone away after I clicked Confirm.
https://crash-stats.mozilla.com/report/index/7e47c858-ee5c-4b25-a15a-a34922140128
(Assignee)

Comment 9

5 years ago
Is this bug still taken? If not, I am willing to take it on.
Thanks.
Flags: needinfo?(riteshnpatel1994)
(Assignee)

Comment 10

5 years ago
Taking since did not get a response.
Assignee: riteshnpatel1994 → yzenevich
(Assignee)

Updated

5 years ago
Flags: needinfo?(riteshnpatel1994)
(Assignee)

Comment 11

5 years ago
Created attachment 8375822 [details] [diff] [review]
819291 patch

Added an assertion and the handler for null.
Attachment #8375822 - Flags: review?(surkov.alexander)
Comment on attachment 8375822 [details] [diff] [review]
819291 patch

Review of attachment 8375822 [details] [diff] [review]:
-----------------------------------------------------------------

r=me, thanks
Attachment #8375822 - Flags: review?(surkov.alexander) → review+
https://hg.mozilla.org/mozilla-central/rev/55066842727a
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
You need to log in before you can comment on or make changes to this bug.