Closed Bug 819425 Opened 7 years ago Closed 6 years ago

Intermittent crash in test_tcpsocket_ipc.js,test_geolocation_timeout_wrap.js [@ PR_NotifyCondVar][@ XPCJSRuntime::WatchdogMain(void*)]

Categories

(Core :: Networking, defect, critical)

x86_64
macOS
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: emorley, Unassigned)

References

Details

(Keywords: crash, intermittent-failure)

Crash Data

Rev4 MacOSX Lion 10.7 mozilla-inbound opt test xpcshell on 2012-12-05 15:11:26 PST for push 84f3936e91a7

slave: talos-r4-lion-078

https://tbpl.mozilla.org/php/getParsedLog.php?id=17646210&tree=Mozilla-Inbound

{
child: TEST-INFO | /Users/cltbld/talos-slave/test/build/xpcshell/tests/dom/network/tests/unit/test_tcpsocket.js | got expected: clientclose

child: TEST-INFO | (xpcshell/head.js) | test 2 pending
TEST-INFO | /Users/cltbld/talos-slave/test/build/xpcshell/tests/dom/network/tests/unit/test_tcpsocket.js | Starting cleanup

child: TEST-INFO | /Users/cltbld/talos-slave/test/build/xpcshell/tests/dom/network/tests/unit/test_tcpsocket.js | Cleaning up

child: TEST-INFO | (xpcshell/head.js) | test 3 pending

child: TEST-INFO | (xpcshell/head.js) | test 3 finished

child: TEST-INFO | (xpcshell/head.js) | test 2 finished

child: TEST-INFO | (xpcshell/head.js) | test 1 finished

child: TEST-INFO | (xpcshell/head.js) | exiting test

child: TEST-PASS | (xpcshell/head.js) | 3 (+ 0) check(s) passed

child: TEST-INFO | (xpcshell/head.js) | 0 check(s) todo
child: CHILD-TEST-COMPLETED
parent: TEST-INFO | (xpcshell/head.js) | test 1 finished

parent: TEST-INFO | (xpcshell/head.js) | exiting test

parent: TEST-INFO | (xpcshell/head.js) | No (+ 0) checks actually run
TCPSocket: close called

NOTE: child process received `Goodbye', closing down
<<<<<<<
Downloading symbols from: http://ftp-scl3.mozilla.com/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-macosx64/1354745460/firefox-20.0a1.en-US.mac.crashreporter-symbols.zip
PROCESS-CRASH | /Users/cltbld/talos-slave/test/build/xpcshell/tests/dom/network/tests/unit_ipc/test_tcpsocket_ipc.js | application crashed [@ PR_NotifyCondVar]
Crash dump filename: /Users/cltbld/talos-slave/test/build/xpcshell/tests/dom/network/tests/unit_ipc/F5B48A14-36FE-44A2-A935-29E5E147FE98.dmp
Operating system: Mac OS X
                  10.7.2 11C74
CPU: amd64
     family 6 model 23 stepping 10
     2 CPUs

Crash reason:  EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
Crash address: 0x0

Thread 6 (crashed)
 0  libnspr4.dylib!PR_NotifyCondVar [ptsynch.c : 280 + 0x0]
    rbx = 0x0000000000000000   r12 = 0x0000000000003903
    r13 = 0x000000010708a000   r14 = 0x0000000106674370
    r15 = 0x00000001048c6ad0   rip = 0x00000001048c02fa
    rsp = 0x0000000107089eb0   rbp = 0x0000000107089ec0
    Found by: given as instruction pointer in context
 1  XUL!XPCJSRuntime::WatchdogMain(void*) [XPCJSRuntime.cpp : 1028 + 0xe]
    rbx = 0x0000000106674000   r12 = 0x0000000000003903
    r13 = 0x000000010708a000   r14 = 0x0000000106674370
    r15 = 0x00000001048c6ad0   rip = 0x0000000100b56b7d
    rsp = 0x0000000107089ed0   rbp = 0x0000000107089ee0
    Found by: call frame info
 2  libnspr4.dylib!_pt_root [ptthread.c : 156 + 0x6]
    rbx = 0x0000000104f1aeb0   r12 = 0x0000000000003903
    r13 = 0x000000010708a000   r14 = 0x0000000000000001
    r15 = 0x00000001048c6ad0   rip = 0x00000001048c6b9b
    rsp = 0x0000000107089ef0   rbp = 0x0000000107089f10
    Found by: call frame info
 3  libsystem_c.dylib + 0x4e8be
    rbx = 0x000000000601002a   r12 = 0x0000000000003903
    r13 = 0x000000010708a000   r14 = 0x0000000104f1aeb0
    r15 = 0x00000001048c6ad0   rip = 0x00007fff85ec58bf
    rsp = 0x0000000107089f20   rbp = 0x0000000107089f50
    Found by: call frame info
 4  libsystem_c.dylib + 0x51b74
    rip = 0x00007fff85ec8b75   rsp = 0x0000000107089f60
    rbp = 0x0000000107089f78
    Found by: stack scanning
 5  libnspr4.dylib + 0x1dacf
    rip = 0x00000001048c6ad0   rsp = 0x000000010708a050
    Found by: stack scanning
}
Duplicate of this bug: 865077
https://tbpl.mozilla.org/php/getParsedLog.php?id=23599663&tree=Mozilla-Inbound
Summary: Intermittent crash in test_tcpsocket_ipc.js [@ PR_NotifyCondVar | XPCJSRuntime::WatchdogMain(void*)] → Intermittent crash in test_tcpsocket_ipc.js,test_geolocation_timeout_wrap.js [@ PR_NotifyCondVar | XPCJSRuntime::WatchdogMain(void*)]
Summary: Intermittent crash in test_tcpsocket_ipc.js,test_geolocation_timeout_wrap.js [@ PR_NotifyCondVar | XPCJSRuntime::WatchdogMain(void*)] → Intermittent crash in test_tcpsocket_ipc.js,test_geolocation_timeout_wrap.js [@ PR_NotifyCondVar][@ XPCJSRuntime::WatchdogMain(void*)]
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.