If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

tabs from last time come up instead of "show my home page"

RESOLVED INVALID

Status

()

Firefox
Private Browsing
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: juanb, Unassigned)

Tracking

({qawanted})

Trunk
x86
Mac OS X
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20121207])

(Reporter)

Description

5 years ago
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:20.0) Gecko/20121207 Firefox/20.0

Using latest-birch I restarted the browser and the tabs from last time were restored despite the "show my home page" setting.

Steps:
1. Run latest birch nightly and go to the preferences and set "when nightly starts" to "show my home page"
2. Open a few tabs in the window.
3. Open another window in PB mode using command-shift-p
4. Open a few tabs in that PB window
5. In the first window go to http://ted.mielczarek.org/mozilla/crashme.html and install the extension. Restart when prompted

Expected: When the application restarts I should get an empty window.[1]

Actual: The first window with a set of tabs comes up. 

1. Is this intended in the case of restarting due to add-on installations? Filing just in case.
(Reporter)

Updated

5 years ago
Whiteboard: [testday-20121207]
Hmm, I don't think that this has changed with per-window private browsing.  Try running the same steps in a regular Nightly outside of PB mode, and I believe you will observe the same (the session being restored.)
Blocks: 463027
Marking as unconfirmed until we have more information here.
Status: NEW → UNCONFIRMED
Ever confirmed: false
Keywords: qawanted
Tested in Firefox 18.  This behavior has not changed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.