Wifi hotspot not working after reboot

RESOLVED DUPLICATE of bug 815070

Status

RESOLVED DUPLICATE of bug 815070
6 years ago
6 years ago

People

(Reporter: ggrisco, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Reporter)

Description

6 years ago
1. Turned on Wi-Fi hostpot from Internet Sharing page
2. Restarted the device

Expected result:  other device should be able to find the hotspot
Actual result:  device shows Wi-Fi hostpot still in On state, but other device can't connect to it.

3. turn Wi-Fi hostpot off
4. turn Wi-Fi hostpot back on

Actual result:  Wifi hotspot cannot be turned back on.
(Reporter)

Updated

6 years ago
blocking-basecamp: --- → ?
(Reporter)

Updated

6 years ago
Depends on: 802677
I reproduced something like this
 (1) Make data call, enable wi-fi hotspot
 (2) Reboot

After rebooting, my phone wouldn't re-establish a data connection.  Disabling/reenabling data and hotspot didn't fix that.

 (3) Reboot
 (4) Re-enable hotspot

On first press, the checkbox went back disabled.  (I REALLY hate that bug.)  On second try, the connection was reestablished.

ggrisco how does this line up with your results?  I want to ensure we're talking about the same bug.
Status: UNCONFIRMED → NEW
No longer depends on: 802677
Ever confirmed: true
Flags: needinfo?(ggrisco)
Whups, sorry about that.
Blocks: 802677
(Reporter)

Comment 3

6 years ago
After the first reboot, it's true, data connection was not re-established even though the setting shows data enabled.  I wasn't able to correct this with subsequent reboots though.  Even after turning data off then back on I still cannot get a data connection.
Flags: needinfo?(ggrisco)
Is it related to mobile data connection can't be turned on ? Or something else. 
Not sure if Bug 815070 is related - [Wifi Tethering] Wait driver ready before turning on Wifi tethering.
(In reply to ggrisco from comment #3)
> After the first reboot, it's true, data connection was not re-established
> even though the setting shows data enabled.  I wasn't able to correct this
> with subsequent reboots though.  Even after turning data off then back on I
> still cannot get a data connection.

The wifi hotspot depends on mobile data connection. So we have to establish mobile data 
connection first before turning on wifi hotspot. 
Also, could you please help to check if applying Bug 815070 resolving this bug ?
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 815070
Dupe is a blocker so bb+.
blocking-basecamp: ? → +
You need to log in before you can comment on or make changes to this bug.