some urls resulting from add-on installation in PB mode show in about:cache

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: jbecerra, Unassigned)

Tracking

({qawanted})

20 Branch
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20121207])

Using latest birch nightly, if I install an add-on in a PB window and restart there will be some AMO urls left in about:cache?device=disk. Those seem to be the URLs that you hit when you click the "install" button in the addon page. It doesn't seem serious, but I didn't expect to see anything related to AMO there.

Steps:
1. Open a PB window using command-shift-p
2. Go to addons.mozilla.org
3. Look for "timer fire"
4. Install the add-on and restart
5. Go to about:cache and click on "list cached entries" under Disk Cache Device
6. Look for "addon"

Expected: No urls containing "addon"

Actual: Some urls with addos.mozilla.org
Whiteboard: [testday-20121207]
Can you please post the URLs that you're seeing here?  Thanks!
Blocks: PBnGen
My suspicion is that this is fine, since you're making a persistent change to the browser and these are related to that change.
Marking as unconfirmed until we have more information here.
Status: NEW → UNCONFIRMED
Ever confirmed: false
Keywords: qawanted
This is fine, the add-on installation itself is persisted, and we do not want to prevent people from installing add-ons in private windows.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.