cannot change from modern skin

RESOLVED WORKSFORME

Status

Core Graveyard
Skinability
P2
major
RESOLVED WORKSFORME
17 years ago
9 years ago

People

(Reporter: andreww, Unassigned)

Tracking

({helpwanted})

Trunk
Future
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
steps to reproduce.
Get a windows or mac build around 05200108
go to view-->apply theme --> classic

expected results:
the theme changes to classic (assuming you are in modern)

actual results:
nothing happens or changes.

Comment 1

17 years ago
Andrew, I think this bug is a dup of 81197 though.
http://bugzilla.mozilla.org/show_bug.cgi?id=81197
Very much confirmed! This bug looks really bad. Tested on a Windows 2000 
Netscape commercial build.
Severity: normal → major
Keywords: mozilla0.9.2, nsbeta1, nsCatFood
OS: Mac System 8.5 → All
Hardware: Macintosh → All

Comment 3

17 years ago
yeah I agree, this looks bad.  Happens on win, mac, linux.  Can't switch themes 
and buttons disappear.

Comment 4

17 years ago
in my first session after installing
Windows; U; Win98; en-US; rv:0.9.1) Gecko/20010607
I tried this.  I was able to reproduce the "theme did not
switch" problem, and in addition I crashed.  --talkback report 
coming...

In my second session I tried again and was able to go
back and forth between modern, to classic and back to 
classic..

Comment 5

17 years ago
ok, here is the stack for my crash after theme swtich attempt in first 
session after install.

Incident ID 31462959
Stack Signature nsParser::WillBuildModel 53fe5274
Trigger Time 2001-06-07 18:26:02
Email Address chofmann@netscape.com
User Comments view | apply theme | classic while running in my first session
runing with 0.9.1 builds
Build ID 2001060713
Product ID Netscape6.10B1
Platform ID Win32
Stack Trace
nsParser::WillBuildModel
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 1418]
nsParser::ResumeParse [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 1851]
nsParser::OnStopRequest
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 2353]
nsXBLStreamListener::OnStopRequest
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLService.cpp, line 292]
nsJARChannel::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\protocol\jar\src\nsJARChannel.cpp, line 587]
nsOnStopRequestEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp, line 159]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
nsEventQueueImpl::ProcessPendingEvents
[d:\builds\seamonkey\mozilla\xpcom\threads\nsEventQueue.cpp, line 375]

Comment 6

17 years ago
I just saw the crash on linux.  I went to switch back to modern (from classic) 
and it completely shut down X-Windows. 

Comment 7

17 years ago
*** Bug 84581 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
win32 2001-06-07-13 (latest) 0.9.1 branch build.
tried with new and existing profile:
modern -> classic.  Change doesn't show right away, but I do get a dlg 
recommending that I restart since there could be inconsistencies in the 
application.
classic -> modern.  Change happens right away without restarting.

As to the crash, I saw that once, never again after a few other tries at 
changing themes.   The crash was on exit.

Comment 9

17 years ago
I've verified this bug for all three platforms, windows 98, Linux,
and Mac.

windows 98: (branch build: 2001-06-07-13-0.9.1)

1. Try with new and existing profiles.
2. modern to classic.
3. Unable to switch from modern to classic theme by either
   (a) selecting View > Apply Theme.. > classic
                    or
   (b) selecting Edit > Preferences > Appearances > Themes > classic
4. The (a) and (b) in step #3 do not work at all. It only happens when first
   time that follow step 3a or 3b.
5. Keep repeat either step #3a or #3b and later let you switch from modern
   to classic theme. However, the "OK" button does not work in the 
   themes preferences dialog.
Note: I've seen on the early commercial build that switching themes-
      the browser crashes, but not on the branch build though.
--------------------------------------------------------

Linux; redhat 6.2 (branch build: 2001-06-07-13-0.9.1)

1. Try with new and existing profiles.
2. modern to classic.
3. On linux, it let you switch from modern to classic by either
    (a) selecting View > Apply Theme.. > classic
                         or
    (b) selecting Edit > Preferences > Appearances > Themes > classic

--------------------------------------------------------

Mac laptop G3, OS: 9.1 (branch build: 2001-06-07-11-0.9.1)

1. Try with new and existing profiles.
2. modern to classic.
3. Unable to switch from modern to classic theme by either
    (a) selecting View > Apply theme... > classic
                  or
    (b) selecting Edit > Preferences > Appearances > Themes > classic
4. The step 3a and 3b do not work at all. It only happens when first time
   that follow step 3a or 3b.
5. Keep repeat step 3a or 3b for couple times, then it let you switch from
   moden to classic theme. However, the "OK" button does not work in the
themes preferences dialog.
if we make it so that skin switching is deferred till restart, this is not
critical for the Netscape upcoming release. However it seems that the problem
here was reported elsewhere regarding the missing navigatorNS.css file in
Classic so the fix may be easy. 
Keywords: nsbeta1, nsCatFood → nsbeta1-, nsCatFood-
Priority: -- → P2
Target Milestone: --- → mozilla1.0

Comment 11

17 years ago
Lisa, I could reproduce on Linux today using the new or existing profiles,
the browser crashes on branch build: (2001-06-07-13-0.9.1). Please see
bug 78580 for further detail.

Below here is the talkback report that crashed on Linux switching themes from
modern to classic (branch build: 2001-06-07-13-0.9.1)

Trigger Type:   Program Crash <http://climate/images/spacer.gif> Trigger
Reason:   SIGSEGV: Segmentation Fault: (signal 11)
<http://climate/images/spacer.gif> Call Stack:     (Signature =
nsXBLService::FetchBindingDocument() 136181eb)
     nsXBLService::FetchBindingDocument()  
     nsXBLService::LoadBindingDocumentInfo()  
     nsXBLService::GetBindingInternal()  
     nsXBLService::GetBindingInternal()  
     nsXBLService::BindingReady()  
     nsXBLPrototypeBinding::NotifyBoundElements()  
     nsXBLPrototypeBinding::StyleSheetLoaded()  
     CSSLoaderImpl::InsertSheetInDoc()  
     InsertPendingSheet()  
     nsVoidArray::EnumerateForwards()  
     CSSLoaderImpl::Cleanup()  
     CSSLoaderImpl::SheetComplete()  
     CSSLoaderImpl::ParseSheet()  
     CSSLoaderImpl::DidLoadStyle()  
     SheetLoadData::OnStreamComplete()  
     nsStreamLoader::OnStopRequest()  
     nsJARChannel::OnStopRequest()  
     nsOnStopRequestEvent::HandleEvent()  
     nsARequestObserverEvent::HandlePLEvent()  
     PL_HandleEvent()  
     PL_ProcessPendingEvents()  
     nsEventQueueImpl::ProcessPendingEvents()  
     nsAppShell::Spindown()  
     nsAppShell::Run()  
     nsAppShellService::Run()  
     main1()  
     main()  
     libc.so.6 + 0x189cb (0x404409cb)  
<http://climate/images/spacer.gif> 

Mass move skinability bugs to nobody@mozilla.org, helpwanted. 
Assignee: ben → nobody
Keywords: helpwanted

Comment 13

16 years ago
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1

Comment 14

16 years ago
What is the status of this bug?.

Comment 15

15 years ago
Switching themes (on restart) exhibits none of those problems nowadays, does it?

Comment 16

14 years ago
retargeting
Target Milestone: mozilla1.0.1 → Future

Comment 17

14 years ago
Theme switching only after restart nowadays,
possible dup bug 81197 WFM.
=> WFM
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

9 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.