Closed Bug 819813 Opened 10 years ago Closed 8 years ago

Some images do not appear due to UA sniffing bug in SlideDeck 1.2.5 detecting Firefox 20 as Firefox 2

Categories

(Web Compatibility :: Desktop, defect)

x86
Windows 7
defect
Not set
normal

Tracking

(firefox20-)

RESOLVED WORKSFORME
Tracking Status
firefox20 - ---

People

(Reporter: over68, Unassigned)

References

()

Details

(Keywords: regression)

Looks like builds on inbound from 11/21 still don't have this bug, so there's a good chance this is fallout from one of the non-merge changesets in that range.
Regression range using mozilla-central hourly builds from that day: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cf8750abee06&tochange=669ac8371d19

All that happened there is the version bump from 19 to 20.  So presumably this is a bug in the UA sniffing the site does...
Ah, and there's a nice console.log message:

[21:46:23.231] This web browser is not supported by SlideDeck. Please view this page in a modern, CSS3 capable browser or a current version of Inernet Explorer

The relevant script is obfuscated, but deobfuscating it and running through jsbeautifier gives me this gem:

  if ((D.browser.opera && D.browser.version < "10.5") || D.browser.msie6 ||
     D.browser.firefox2 || D.browser.firefox30) {
    if (typeof (console) != "undefined") {
        if (typeof (console.error) == "function") {
            console.error("This web browser is not supported by SlideDeck. Please view this page in a modern, CSS3 capable browser or a current version of Inernet Explorer")
        }
    }
    return false
  }

where D.browser stuff is defined like so:

          this.browser = {
              firefox: F.match(/firefox/) ? true : false,
              firefox2: F.match(/firefox\/2/) ? true : false,
              firefox30: F.match(/firefox\/3\.0/) ? true : false,

So "Firefox/20.0" matches the regexp for "firefox2" and things go sour.

Reporter, are you affiliated with the site?  Can you report the problem to them?
Assignee: nobody → english-us
Status: UNCONFIRMED → NEW
Component: General → English US
Ever confirmed: true
Keywords: regression
Product: Core → Tech Evangelism
Version: 20 Branch → unspecified
The site seems to be using http://www.slidedeck.com/ version 1.2.5, which is a product they shipped in 2011-06 according to the copyright comment!

I've sent some feedback to the library authors, for whatever that's worth.
Summary: Some images do not appear → Some images do not appear due to UA sniffing bug in SlideDeck 1.2.5 detecting Firefox 20 as Firefox 2
(In reply to Boris Zbarsky (:bz) from comment #4)
> Reporter, are you affiliated with the site?  Can you report the problem to them?

No, I'm not affiliated with the site, I will try inform them of the problem.
This happens also in http://www.slidedeck.com

After clicking the picture does not change.

See http://i449.photobucket.com/albums/qq217/movh/87524_zps4791c412.png
For my future reference, http://dtelepathy.zendesk.com/requests/3504 is the bug I filed on SlideDeck; they're working on fixing it.  Unfortunately, it looks like you have to create an account to see the bug report...

Of course even if they fix it that won't magically fix sites.

> This happens also in http://www.slidedeck.com

Yes, it's the same broken code.  ;)
The SlideDeck folks are reolling out a fix, and planning to mail their users to update...
Thanks for chasing down this evangelism issue Boris, no need to track on our side since it looks like there will be a fix in place way before 20 is released.
Well, there will be a fix in the SlideDeck code.  Whether sites that use it update... we'll see.  :(
The site is working for me Firefox 32.0.3
Assignee: english-us → nobody
Status: NEW → RESOLVED
Closed: 8 years ago
Component: English US → Desktop
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.