Last Comment Bug 819825 - some ICE/STUN negotiations hang or crash on Android in mbslen()
: some ICE/STUN negotiations hang or crash on Android in mbslen()
Status: RESOLVED FIXED
[WebRTC][blocking-webrtc-][qa-]
:
Product: Core
Classification: Components
Component: WebRTC (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: mozilla20
Assigned To: Dan Mosedale (:dmose)
: Jason Smith [:jsmith]
:
Mentors:
Depends on:
Blocks: android-webrtc
  Show dependency treegraph
 
Reported: 2012-12-09 18:06 PST by Dan Mosedale (:dmose)
Modified: 2012-12-14 09:03 PST (History)
4 users (show)
dmose: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
WIP patch 1: abort the function rather than trying to handle a null return from setlocale() (923 bytes, patch)
2012-12-09 18:06 PST, Dan Mosedale (:dmose)
no flags Details | Diff | Splinter Review
version2: null-check set-locale, and abort the function if that fails (1.05 KB, patch)
2012-12-13 11:07 PST, Dan Mosedale (:dmose)
dmose: review+
Details | Diff | Splinter Review

Description Dan Mosedale (:dmose) 2012-12-09 18:06:47 PST
Created attachment 690253 [details] [diff] [review]
WIP patch 1: abort the function rather than trying to handle a null return from setlocale()

After apply the build patches for Android in the dependency tree for bug 750869, the ICE unittest hangs or crashes in mbslen.  The problem is that setlocale() on Android returns null.

The calling code actually isn't really caring about this function, excitingly.  Here's a patch that makes things run further, but it would be good to verify that's impossible/hard to get UTF8 before we just punt.
Comment 1 Dan Mosedale (:dmose) 2012-12-13 11:07:32 PST
Created attachment 691901 [details] [diff] [review]
version2: null-check set-locale, and abort the function if that fails

This strikes me as somewhat more maintainable/readable code than adding another ifdef clause.  And it makes the ice unit tests pass.
Comment 2 Dan Mosedale (:dmose) 2012-12-13 11:10:30 PST
Comment on attachment 691901 [details] [diff] [review]
version2: null-check set-locale, and abort the function if that fails

r=abr over IRC
Comment 3 Dan Mosedale (:dmose) 2012-12-13 11:15:03 PST
Try server build:

https://tbpl.mozilla.org/?tree=Try&rev=6b62c415dd7f
Comment 4 Dan Mosedale (:dmose) 2012-12-13 16:56:12 PST
Pushed to mozilla-inbound:

https://hg.mozilla.org/integration/mozilla-inbound/rev/b9a891c0a6e7

in-testsuite+, as this was caught by ice_unittest, and this fix makes that test pass.
Comment 5 Ed Morley [:emorley] 2012-12-14 07:35:54 PST
https://hg.mozilla.org/mozilla-central/rev/b9a891c0a6e7

Note You need to log in before you can comment on or make changes to this bug.