Closed Bug 819827 Opened 8 years ago Closed 8 years ago

Preprocessing of the actual channel removed by bug 721165

Categories

(Toolkit :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla20
Tracking Status
firefox18 + fixed
firefox19 + fixed
firefox20 --- fixed
b2g18 --- fixed

People

(Reporter: robert.strong.bugs, Assigned: Gavin)

References

Details

(Keywords: regression)

Attachments

(1 file)

Preprocessing of the actual update channel was added as a fallback in case the channel preferences file was removed (this has happened due to 3rd party software) so we can still update clients. This needs to be added back.

The relevant change is in attachment #659758 [details] [diff] [review] in bug 721165. Search for @MOZ_UPDATE_CHANNEL@
Sounds like we need to fix this for 18?
That would be a good thing imo
Attached patch patchSplinter Review
Assignee: andres → gavin.sharp
Status: NEW → ASSIGNED
Attachment #691098 - Flags: review?(robert.bugzilla)
Attachment #691098 - Flags: review?(robert.bugzilla) → review+
Comment on attachment 691098 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 721165 
User impact if declined: updates may fail for users whose channel prefs file was removed (apparently this happens to people somehow?)
Testing completed (on m-c, etc.): none
Risk to taking this patch (and alternatives if risky): it only affects the fallback value - getting that wrong is no worse than the current state. Other issues it could cause (making the file invalid JS somehow) would blow tests up quite visibly.
String or UUID changes made by this patch: none
Attachment #691098 - Flags: approval-mozilla-beta?
Attachment #691098 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/31ff0e486fb5
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Comment on attachment 691098 [details] [diff] [review]
patch

Given the very low risk profile here, let's land on Aurora/Beta.
Attachment #691098 - Flags: approval-mozilla-beta?
Attachment #691098 - Flags: approval-mozilla-beta+
Attachment #691098 - Flags: approval-mozilla-aurora?
Attachment #691098 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.