Closed Bug 819828 Opened 9 years ago Closed 9 years ago

Live Ogg/Theora playback makes the UI slow

Categories

(Core :: Audio/Video, defect)

20 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 819377
Tracking Status
firefox20 + fixed

People

(Reporter: ds, Assigned: padenot)

References

Details

(Keywords: perf, regression)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121129151842

Steps to reproduce:

Playback of live Ogg/Theora streams, such as http://preston.entropywave.com/encoder0 .  (Note: this stream is sometimes configured for Flash, let me know if you plan to test, and I'll switch it back to Ogg/Theora.)


Actual results:

UI is very choppy.  CPU usage is 114%.

In ff 17, UI is normal, CPU usage is minimal.
Fails in 2012-11-30 nightly.
Same behavior with live WebM streams.  Non-live streams are not affected.
Status: UNCONFIRMED → NEW
Component: Untriaged → Video/Audio
Ever confirmed: true
Product: Firefox → Core
I suspected bug 455165, but that shouldn't have landed until Dec. 1st.
UI become not response.

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/dd00a3bad021
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20 Firefox/20.0a1 ID:20121122020052
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/dd00a3bad021
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20 Firefox/20.0a1 ID:20121122020052
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c6af8da7bfa3&tochange=a20b32f37e7a

Regressed by:  Bug 495040
Oops, 

Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/a20b32f37e7a
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20 Firefox/20.0a1 ID:20121122023852
So isn't this just a Dupe of Bug 819377?
It's possible they have the same underlying cause, but this one is triggered specifically by live streams, whereas 819377 is not. I'd leave them as separate bugs until we know more.
Tracking and passing to Jet to find an owner of this regression.
Assignee: nobody → bugs
David, could you provide a live stream that happened to trigger the issue you are seeing? I've got a lead based on bug 819377 and would like to check if it is the same problem.
Paul, done.  See link above, or the http:// equivalent.
To Paul as noted in comment 9.
Assignee: bugs → paul
After investigation, this is indeed a dup. I've got a patch that fixes the issue and is green locally, currently going through try.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 819377
You need to log in before you can comment on or make changes to this bug.