If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Live Ogg/Theora playback makes the UI slow

RESOLVED DUPLICATE of bug 819377

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 819377
5 years ago
5 years ago

People

(Reporter: David Schleef, Assigned: padenot)

Tracking

({perf, regression})

20 Branch
x86_64
Linux
perf, regression
Points:
---

Firefox Tracking Flags

(firefox20+ fixed)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121129151842

Steps to reproduce:

Playback of live Ogg/Theora streams, such as http://preston.entropywave.com/encoder0 .  (Note: this stream is sometimes configured for Flash, let me know if you plan to test, and I'll switch it back to Ogg/Theora.)


Actual results:

UI is very choppy.  CPU usage is 114%.

In ff 17, UI is normal, CPU usage is minimal.
(Reporter)

Comment 1

5 years ago
Fails in 2012-11-30 nightly.
Keywords: regressionwindow-wanted
(Reporter)

Comment 2

5 years ago
Same behavior with live WebM streams.  Non-live streams are not affected.
Status: UNCONFIRMED → NEW
Component: Untriaged → Video/Audio
Ever confirmed: true
Product: Firefox → Core
I suspected bug 455165, but that shouldn't have landed until Dec. 1st.

Comment 4

5 years ago
UI become not response.

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/dd00a3bad021
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20 Firefox/20.0a1 ID:20121122020052
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/dd00a3bad021
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20 Firefox/20.0a1 ID:20121122020052
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c6af8da7bfa3&tochange=a20b32f37e7a

Regressed by:  Bug 495040
Blocks: 495040
tracking-firefox20: --- → ?
Keywords: regressionwindow-wanted → perf, regression

Comment 5

5 years ago
Oops, 

Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/a20b32f37e7a
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20 Firefox/20.0a1 ID:20121122023852
So isn't this just a Dupe of Bug 819377?
It's possible they have the same underlying cause, but this one is triggered specifically by live streams, whereas 819377 is not. I'd leave them as separate bugs until we know more.
Tracking and passing to Jet to find an owner of this regression.
Assignee: nobody → bugs
tracking-firefox20: ? → +
(Assignee)

Comment 9

5 years ago
David, could you provide a live stream that happened to trigger the issue you are seeing? I've got a lead based on bug 819377 and would like to check if it is the same problem.
(Reporter)

Comment 10

5 years ago
Paul, done.  See link above, or the http:// equivalent.

Comment 11

5 years ago
To Paul as noted in comment 9.
Assignee: bugs → paul
(Assignee)

Comment 12

5 years ago
After investigation, this is indeed a dup. I've got a patch that fixes the issue and is green locally, currently going through try.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 819377

Updated

5 years ago
status-firefox20: --- → fixed
You need to log in before you can comment on or make changes to this bug.