Closed Bug 819845 Opened 7 years ago Closed 7 years ago

Update WebIDL bindings to changes to sequence/dictionary distinguishability

Categories

(Core :: DOM: Core & HTML, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla20

People

(Reporter: bzbarsky, Assigned: bzbarsky)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

See https://www.w3.org/Bugs/Public/show_bug.cgi?id=16767 and http://dev.w3.org/cvsweb/2006/webapi/WebIDL/Overview.xml.diff?r1=1.573;r2=1.575;f=h

The changes are as follows:

1)  Dictionaries are now no longer distinguishable from sequences or IDL arrays.
2)  Conversion to a sequence no longer involves checking for an actual array
    object.
Though note that the spec still has issues in terms of how overload resolution should work with the new setup.  Need to sort that out before we change this.
Attachment #690293 - Attachment is obsolete: true
Note that maybe we should rename IsArrayLike to IsConvertibleToSequence....
Whiteboard: [need review]
http://hg.mozilla.org/integration/mozilla-inbound/rev/ad6784f8e19b
Flags: in-testsuite+
Whiteboard: [need review]
Target Milestone: --- → mozilla20
https://hg.mozilla.org/mozilla-central/rev/ad6784f8e19b
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Duplicate of this bug: 742204
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.