Closed Bug 819915 Opened 7 years ago Closed 7 years ago

Multiple CSS backgrounds don't show correctly when disabled HWA

Categories

(Core :: Layout, defect)

18 Branch
x86_64
All
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla20
Tracking Status
firefox18 + verified
firefox19 + verified
firefox20 + verified
b2g18 --- fixed

People

(Reporter: weby, Assigned: mattwoodrow)

References

()

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:20.0) Gecko/20121210 Firefox/20.0
Build ID: 20121210030747

Steps to reproduce:

Creating a website with multiple background images.

A sample website :
http://pokemon-ranch.com

It worked in nightly versions 2012-12-08 and earlier, and works in the latest nightly in windows.

Does not work in 2012-12-09 and 2012-12-10 Linux x86_64 (Arch Linux).


Actual results:

Only the last background-image appears, instead of the two.

It appears like this :
http://up.levert.ch/7b2e57-Screenshot-pr.png


Expected results:

Both images should appear correctly, like in this screenshot :

http://www.plixup.com/pics_core3/13551455539297pkmranch.png
I can reproduce this Issue on Windows 7 x64 only with HWA turned off/Safe-Mode.
OS: Linux → All
I should have mentioned that I too tried with safe mode on and off, same issue both ways.

Tried with HWA off right now, same issue.

Tried to write the css in different ways (shorthand and multiline), same issue too.

Also, in firebug, the css appears exactly as I wrote it, and the pictures, by hovering their url in firebug, pop up correctly.
I can reproduce this in nightly 2012-12-11, linux x64
Those are tested in WOW64 and x64 :
HWA OFF- Firefox 18.0b1 - FAIL
HWA ON - Firefox 18.0b1 - PASS
HWA OFF- Firefox 18.0b2 - FAIL
HWA ON - Firefox 18.0b2 - PASS
HWA OFF- Firefox 18.0b3 - FAIL
HWA ON - Firefox 18.0b3 - PASS
HWA OFF- Firefox 18.0b3 (portable) - FAIL
HWA ON - Firefox 18.0b3 (portable) - PASS
HWA OFF- Palemoon 15.3.2 - PASS
HWA ON - Palemoon 15.3.2 - PASS
Firefox 17.0.1 - PASS

Those are tested in Linux x64 :
Firefox 17.0.1 - PASS
Nightly 2012-11-20 - FAIL
Nightly 2012-12-11 - FAIL
Nightly 2012-12-10 - FAIL
Nightly 2012-12-08 - FAIL
Nightly 2012-12-01 - FAIL
Note that the "GPU Accelerated Windows" shows "(0/1) basic" in the support page, whether the acceleration is enabled or disabled in the options. 


Seems the bug is caused by the arrival of the version 18, and appears only with HWA off (or if HWA does not work correctly). I sure updated my nvidia card driver to the latest recently, this may be the cause of the dysfunctional HWA on my computer, and that's probably why I saw the 2012-12-08 version working. Will try to downgrade my nvidia driver.
Tried with nightly 2012-12-11 with HWA on (forced in about:config), shows correctly, while the issue reappears with HWA off.
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/58ebb638a7ea
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121115172150
Bad:
http://hg.mozilla.org/mozilla-central/rev/a7ed19f7d21a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121116090659
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=58ebb638a7ea&tochange=a7ed19f7d21a


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/244493403e89
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121115151651
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/2c2c6ddb6fe6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121115163151
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=244493403e89&tochange=2c2c6ddb6fe6

Suspected: Bug 810470
Blocks: 810470
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout
Ever confirmed: true
Product: Firefox → Core
Summary: Multiple CSS backgrounds don't show correctly → Multiple CSS backgrounds don't show correctly without HWA
Version: 20 Branch → 18 Branch
Summary: Multiple CSS backgrounds don't show correctly without HWA → Multiple CSS backgrounds don't show correctly when disabled HWA
Sending to Matt to take a look and hopefully resolve in a low risk manner before Tuesday's beta 5 go-to-build. Given where we are in the cycle, and the minimal user impact here, this will not block the FF18 release.
Assignee: nobody → matt.woodrow
We still need this to return false if there are multiple images since we were using the cached background image for the first image to paint the second.
Attachment #692788 - Flags: review?(roc)
Comment on attachment 692788 [details] [diff] [review]
Fix IsSingleFixedPosition

Review of attachment 692788 [details] [diff] [review]:
-----------------------------------------------------------------

We should have a test here.
Attachment #692788 - Flags: review?(roc) → review+
https://hg.mozilla.org/mozilla-central/rev/9d6e95e77855
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Keywords: qawanted, verifyme
QA Contact: jbecerra
(In reply to Matt Woodrow (:mattwoodrow) from comment #10)
> https://hg.mozilla.org/integration/mozilla-inbound/rev/9d6e95e77855

:Matt , can you please prepare required branch patches & provide risk analysis to consider uplifts ?
Juanb, can we please get some verification around this before we consider it for beta uplift ?Thanks !
Comment on attachment 692788 [details] [diff] [review]
Fix IsSingleFixedPosition

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 810470
User impact if declined: Multiple backgrounds drawn incorrectly when we don't have hardware acceleration.
Testing completed (on m-c, etc.): Landed on m-c.
Risk to taking this patch (and alternatives if risky): Very low, this just reverts one chunk from the regressing patch to what it was previously.
String or UUID changes made by this patch: None
Attachment #692788 - Flags: approval-mozilla-beta?
Attachment #692788 - Flags: approval-mozilla-aurora?
Comment on attachment 692788 [details] [diff] [review]
Fix IsSingleFixedPosition

Approving on aurora, and waiting for QA feedback before considering for beta.
Attachment #692788 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
http://pokemon-ranch.com/ with HWA off
Broken - nightly 2012-12-17
Fixed  - nightly 2012-12-18
Win 7 x64, Ubuntu 12.04, Mac OS X 10.7.5
Comment on attachment 692788 [details] [diff] [review]
Fix IsSingleFixedPosition

Approving on beta, considering the QA verification & as the patch itself is low risk.
Attachment #692788 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Nightly 2012-12-17 - FAIL
Nightly 2012-12-18 - PASS

Arch Linux x64.

Also, moved the test page from http://pokemon-ranch.com/ to http://pokemon-ranch.com/test.php.

Please use this page for further tests.
(In reply to Paul Silaghi [QA] from comment #16)
> http://pokemon-ranch.com/ with HWA off
> Broken - nightly 2012-12-17
> Fixed  - nightly 2012-12-18
> Win 7 x64, Ubuntu 12.04, Mac OS X 10.7.5

Verified fixed FF 18b5 Win 7 x64, Ubuntu 12.04, Mac OS X 10.8.2
Verified fixed FF 19b3 Win 7 x64, Ubuntu 12.04, Mac OS X 10.8.2
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.