[Apps] Allow to cancel hosted app download

VERIFIED FIXED in Firefox 19

Status

P1
normal
VERIFIED FIXED
6 years ago
11 months ago

People

(Reporter: ferjm, Assigned: ferjm)

Tracking

({feature})

Trunk
B2G C3 (12dec-1jan)
feature
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+, firefox19 fixed, firefox20 fixed, b2g18 fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

6 years ago
We need the ability to cancel hosted app installations in order to fully implement the Gaia app install specs.
More info in Bug 816128.
(Assignee)

Comment 1

6 years ago
Blocker of a blocker, so I guess this one should be bb+ too.
Assignee: nobody → ferjmoreno
Blocks: 816128
blocking-basecamp: --- → ?
(Assignee)

Updated

6 years ago
Depends on: 819971
(Assignee)

Updated

6 years ago
Blocks: 818848
(Assignee)

Updated

6 years ago
Summary: [Apps] Allow to cancel hosted app installations → [Apps] Allow to cancel hosted app download
blocking-basecamp: ? → +
(Assignee)

Comment 2

6 years ago
Created attachment 691327 [details] [diff] [review]
v1

I'd like to do more tests before asking for r?
(Assignee)

Comment 3

6 years ago
Created attachment 691389 [details] [diff] [review]
v1

It seems to be working properly. I'm just updating the patch to remove some trailing white spaces.

This patch won't land until Bug 819971 does.
Attachment #691327 - Attachment is obsolete: true
Attachment #691389 - Flags: review?(fabrice)
Comment on attachment 691389 [details] [diff] [review]
v1

Review of attachment 691389 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/apps/src/Webapps.jsm
@@ +866,5 @@
>        return;
>      }
> +
> +    if (download.cacheUpdate) {
> +      // Cancell hosted app download.

Nit: Cancel

@@ +869,5 @@
> +    if (download.cacheUpdate) {
> +      // Cancell hosted app download.
> +      download.cacheUpdate.cancel();
> +    } else if (download.channel) {
> +      // Cancell packaged app download.

ditto
Attachment #691389 - Flags: review?(fabrice) → review+
(Assignee)

Comment 5

6 years ago
Created attachment 692279 [details] [diff] [review]
v2

I had to modify the patch because of the changes that I've made for Bug 819971. Now we don't use the nsIOfflineCacheUpdateObserver::STATE_CANCELLED state, but we reuse the STATE_ERROR one.

Fabrice, I won't ask you for r? again to not spam your request queue, but feel free to take a look at the patch again :).
Attachment #691389 - Attachment is obsolete: true

Updated

6 years ago
Duplicate of this bug: 816128

Updated

6 years ago
Attachment #692279 - Flags: review?(fabrice)
Attachment #692279 - Flags: review?(fabrice) → review+
Duplicate of this bug: 816128
Driver retriage: QA, please ensure scenario in bug 816128 is covered. They are 100% identical, but want to ensure we're not missing anything.

Also, can this land now?
Keywords: feature
Priority: -- → P1
Target Milestone: --- → B2G C3 (12dec-1jan)
(Assignee)

Comment 9

6 years ago
We have to wait for Bug 819971 to land. Hopefully that will happen today.
https://hg.mozilla.org/mozilla-central/rev/ba2f2f5fb6b2
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Keywords: verifyme
QA Contact: jsmith
https://hg.mozilla.org/releases/mozilla-aurora/rev/9f16f87d783a
https://hg.mozilla.org/releases/mozilla-b2g18/rev/1a054d2478f0
status-b2g18: --- → fixed
status-firefox19: --- → fixed
status-firefox20: --- → fixed
Verified - I've confirmed I cancel a hosted app download preloading appcache.
Status: RESOLVED → VERIFIED
Keywords: verifyme

Updated

11 months ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.