Closed Bug 820123 Opened 7 years ago Closed 7 years ago

When you drag and drop a web site icon to some location it often produces a generic shortcut icon instead of the default Seamonkey logo shortcut icon

Categories

(SeaMonkey :: OS Integration, defect)

SeaMonkey 2.15 Branch
x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 828284

People

(Reporter: thee.chicago.wolf, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0 SeaMonkey/2.15
Build ID: 20121206071748

Steps to reproduce:

I dragged the site icon for https://mail.mozilla.com/home/akeybl@mozilla.com/Release%20Management.html?view=month&date=20121222 to a folder to create a shortcut to the web site.


Actual results:

Instead of the usual Seamonkey shortcut icon, it creates a generic shortcut icon.


Expected results:

Instead of generic shortcut icon, it should create a shortcut icon that shows the Seamonkey logo. I have attached an image showing the generic created icon on the left with an example shortcut icon on the left of correct behavior / appearance.
The favicon of the page is used in my test using:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0 SeaMonkey/2.17a1
CORRECTION: I have attached an image showing the generic created icon on the left with an example shortcut icon on the *RIGHT* of correct behavior / appearance.
So I uninstalled 2.15b3 and went back a few versions (beginning at 2.8 and ending back at 2.15b3) to see if and when it broke. I wasn't able to repro the issue and it *seemed* as if it actually fixed the problem. Seemed but not actually fixed. I can add some more STR and this may not be so much related to drag and dropping of web site icon when this breakage occurs.

1. Visit the above link in my first comment.

2. Drag and drop the site icon to some location to create a shortcut. It *should* create a normal shortcut icon and not a generic one.

3. If a normal icon is created, click the "go to previous page" left arrow in the top right corner of the page (the blue one, next to the word December) which takes you to November.

4. Dragging and dropping this site icon produces a generic shortcut link.

5. If you choose the arrow in the top right corner to go back to December and drag and drop the site icon, it will appear as a normal shortcut link. If you go forward to January and drag and drop the site icon, you will get a generic shortcut icon.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 823118
Component: General → OS Integration
Blocks: 110894
Is this a DUP of Bug 828284 - Force shortcut desktop icons off on Windows XP ?
 
 
Creating the Pref, browser.shell.shortcutFavicons;false, then displays a "SeaMonkey" icon rather then a "Generic" icon on the (XP) desktop.
 
 
Note that even with the Pref, the below URL does revert to a Generic icon, for some reason?

> http://www.videohelp.com/tools
 
 
Mozilla/5.0 (Windows NT 5.1; rv:22.0) Gecko/20100101 Firefox/22.0 SeaMonkey/2.19a2
Build identifier: 20130508013001
Looks like this is now fixed in SM2.19. Drag and drop of site icons produces pretty shortcut icon.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 828284
You need to log in before you can comment on or make changes to this bug.