Closed Bug 820336 Opened 9 years ago Closed 8 years ago

Intermittent testWebContentContextMenu,testPanCorrectness,testAboutPage,testVkbOverlap,testFindInPage,testAddonManager | checking that painted surface loaded - painted surface loaded (x3)

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox19 affected, firefox20 affected)

RESOLVED WORKSFORME
Tracking Status
firefox19 --- affected
firefox20 --- affected

People

(Reporter: emorley, Unassigned)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Android no-ionmonkey Tegra 250 mozilla-inbound opt test robocop on 2012-12-06 12:16:12 PST for push d96db52bedc4

slave: tegra-031

https://tbpl.mozilla.org/php/getParsedLog.php?id=17681853&tree=Mozilla-Inbound

{
1 INFO TEST-START | testWebContentContextMenu
2 INFO TEST-PASS | testWebContentContextMenu | Awesomebar URL typed properly - http://mochi.test:8888/tests/robocop/robocop_big_link.html should equal http://mochi.test:8888/tests/robocop/robocop_big_link.html
long-clicking at 840.0, 103.0
3 INFO TEST-PASS | testWebContentContextMenu | looking for context menu action - found 'Open Link in New Tab'
4 INFO TEST-PASS | testWebContentContextMenu | Number of tabs has increased - 2 should equal 2
5 INFO TEST-PASS | testWebContentContextMenu | Awesomebar URL typed properly - http://mochi.test:8888/tests/robocop/robocop_big_link.html should equal http://mochi.test:8888/tests/robocop/robocop_big_link.html
java.lang.reflect.InvocationTargetException
	at org.mozilla.gecko.RobocopAPI.getViewPixels(RobocopAPI.java:47)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:521)
	at org.mozilla.fennec.FennecNativeDriver.getPaintedSurface(FennecNativeDriver.java:260)
	at org.mozilla.fennec.tests.PixelTest.loadAndGetPainted(PixelTest.java:13)
	at org.mozilla.fennec.tests.PixelTest.loadAndPaint(PixelTest.java:22)
	at org.mozilla.fennec.tests.testWebContentContextMenu.testWebContentContextMenu(testWebContentContextMenu.java:54)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:521)
	at android.test.InstrumentationTestCase.runMethod(InstrumentationTestCase.java:204)
	at android.test.InstrumentationTestCase.runTest(InstrumentationTestCase.java:194)
	at android.test.ActivityInstrumentationTestCase2.runTest(ActivityInstrumentationTestCase2.java:186)
	at org.mozilla.fennec.tests.BaseTest.runTest(BaseTest.java:120)
	at junit.framework.TestCase.runBare(TestCase.java:127)
	at junit.framework.TestResult$1.protect(TestResult.java:106)
	at junit.framework.TestResult.runProtected(TestResult.java:124)
	at junit.framework.TestResult.run(TestResult.java:109)
	at junit.framework.TestCase.run(TestCase.java:118)
	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:169)
	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:154)
	at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:520)
	at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1447)
Caused by: java.lang.OutOfMemoryError
	at java.nio.IntArrayBuffer.<init>(IntArrayBuffer.java:43)
	at java.nio.ReadWriteIntArrayBuffer.<init>(ReadWriteIntArrayBuffer.java:47)
	at java.nio.BufferFactory.newIntBuffer(BufferFactory.java:148)
	at java.nio.IntBuffer.allocate(IntBuffer.java:47)
	at org.mozilla.gecko.gfx.LayerRenderer.getPixels(LayerRenderer.java:269)
	at org.mozilla.gecko.gfx.LayerView.getPixels(LayerView.java:291)
	... 22 more
6 INFO TEST-UNEXPECTED-FAIL | testWebContentContextMenu | checking that painted surface loaded - painted surface loaded
}
Caused by: java.lang.OutOfMemoryError
	at java.nio.IntArrayBuffer.<init>(IntArrayBuffer.java:43)
	at java.nio.ReadWriteIntArrayBuffer.<init>(ReadWriteIntArrayBuffer.java:47)
	at java.nio.BufferFactory.newIntBuffer(BufferFactory.java:148)
	at java.nio.IntBuffer.allocate(IntBuffer.java:47)
	at org.mozilla.gecko.gfx.LayerRenderer.getPixels(LayerRenderer.java:269)
	at org.mozilla.gecko.gfx.LayerView.getPixels(LayerView.java:291)
This might be helpful if we can invoke it when we hit the OOM and somehow pull the hprof file off. It's a binary dump so we can't just dump it to logcat or something.
Attachment #690922 - Flags: review?(gbrown)
Comment on attachment 690922 [details] [diff] [review]
Dump hprof data on demand

Review of attachment 690922 [details] [diff] [review]:
-----------------------------------------------------------------

Cool. It seems like a good idea.
Attachment #690922 - Flags: review?(gbrown) → review+
Do we have some mechanism for pulling files off the device in case of test failure though?
Flags: needinfo?(jmaher)
we can fix our harnesses up to look for /sdcard/*.hprof and pull those up.  Then we would need to cat that into the logfile.  I would imagine putting this in the checkForCrashes routine.
Flags: needinfo?(jmaher)
try run to reproduce this failure: https://tbpl.mozilla.org/?tree=Try&rev=f20ba2b67ed6

(But so far, no luck in over 1000 runs!)
Summary: Intermittent testWebContentContextMenu | checking that painted surface loaded - painted surface loaded (x3) → Intermittent testWebContentContextMenu, testPanCorrectness | checking that painted surface loaded - painted surface loaded (x3)
It's going to be interesting to find out what's actually broken about tegra-031, since this has happened exactly once on slaves which are not 031.
Depends on: tegra-031
https://tbpl.mozilla.org/php/getParsedLog.php?id=20889335&tree=Mozilla-Inbound
Summary: Intermittent testWebContentContextMenu, testPanCorrectness | checking that painted surface loaded - painted surface loaded (x3) → Intermittent testWebContentContextMenu,testPanCorrectness,testAboutPage | checking that painted surface loaded - painted surface loaded (x3)
https://tbpl.mozilla.org/php/getParsedLog.php?id=21159015&tree=Mozilla-Inbound
Summary: Intermittent testWebContentContextMenu,testPanCorrectness,testAboutPage | checking that painted surface loaded - painted surface loaded (x3) → Intermittent testWebContentContextMenu,testPanCorrectness,testAboutPage,testVkbOverlap | checking that painted surface loaded - painted surface loaded (x3)
https://tbpl.mozilla.org/php/getParsedLog.php?id=21176456&tree=Mozilla-Inbound
Summary: Intermittent testWebContentContextMenu,testPanCorrectness,testAboutPage,testVkbOverlap | checking that painted surface loaded - painted surface loaded (x3) → Intermittent testWebContentContextMenu,testPanCorrectness,testAboutPage,testVkbOverlap,testFindInPage | checking that painted surface loaded - painted surface loaded (x3)
https://tbpl.mozilla.org/php/getParsedLog.php?id=21196725&tree=Mozilla-Inbound
Summary: Intermittent testWebContentContextMenu,testPanCorrectness,testAboutPage,testVkbOverlap,testFindInPage | checking that painted surface loaded - painted surface loaded (x3) → Intermittent testWebContentContextMenu,testPanCorrectness,testAboutPage,testVkbOverlap,testFindInPage,testAddonManager | checking that painted surface loaded - painted surface loaded (x3)
(OrangeWFM bugs not modified in > 2 months)
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.