Closed Bug 820346 Opened 8 years ago Closed 8 years ago

Test failure "TabView is not open." in endurance/testTabView_OpenTabViewWithTabs/test1.js

Categories

(Mozilla QA Graveyard :: Mozmill Tests, defect, P3)

x86
Windows XP
defect

Tracking

(firefox19 affected, firefox21 affected)

RESOLVED WORKSFORME
Tracking Status
firefox19 --- affected
firefox21 --- affected

People

(Reporter: AndreeaMatei, Assigned: andrei)

References

()

Details

(Whiteboard: [mozmill-test-failure][endurance] s=130218 u=failure c=tabview p=1)

Happened last night on Windows XP, with Aurora build, fr locale.
Whiteboard: [mozmill-test-failure][endurance]
Priority: -- → P3
Started happening on Nightly builds with Windows 8 x86 in /testTabView_OpenNewTab/test1.js:
http://mozmill-ci.blargon7.com/#/endurance/report/72e15dc943833b8fcba70aeb516c3b1c
Happened again today on Windows NT 6.2.9200 (x86_64) - Firefox 21.0a1:

http://mozmill-ci.blargon7.com/#/endurance/report/ad726b5c70cf80fbf8135edfca41dc8c
Whiteboard: [mozmill-test-failure][endurance] → [mozmill-test-failure][endurance] s=130218 u=failure c=tabview p=1
Assignee: nobody → andrei.eftimie
I've devoted a couple of hours yesterday in trying to reproduce this with no success.

With the news that the Panorama is going out (bug 836758) and we're removing it from our tests in bug 844865 the tests generating this error will be removed.
Depends on: 844865
The test will not be removed for Firefox < 22.0, and those branches are affected.
After investigating this I think the reason for this fail is the fact that we fail to open the Panorama tab view due to a shortkey issue.

I have found Bug 647248 that Henrik fixed a while back by adding .toLocalUpperCase when getting the shortkey "e" from DTDS to tabview.close. I was wondering if we shouldn't add this to tabview.open since it uses the same keys shortcut as tabview.closed .

So far I wasn't able to reproduce a failure either by clear repo runs, or by removing toLocalUpperCase from tabview.close.
Flags: needinfo?(hskupin)
I remember I saw something with this .toLocalUpperCase in a patch from Daniela if I recall well, and after digging then, there was a recently changeset that was switching that value so that we don't need .toLocalUpperCase anymore. I will search that to make sure.
This bug did not reproduce since 5th of February.
Please directly close those bugs as WFM in the future. Doing so now.
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?(hskupin)
Resolution: --- → WORKSFORME
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.