Intermittent dom/workers/test/test_fibonacci.html | Test timed out.

RESOLVED FIXED in mozilla20

Status

()

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: emorley, Assigned: khuey)

Tracking

({intermittent-failure})

Trunk
mozilla20
x86
Windows 7
intermittent-failure
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Rev3 WINNT 5.1 mozilla-inbound opt test mochitest-4 on 2012-12-08 15:36:57 PST for push b5fa6a857c35

slave: talos-r3-xp-042

https://tbpl.mozilla.org/php/getParsedLog.php?id=17754155&tree=Mozilla-Inbound

{
852 INFO TEST-START | /tests/dom/workers/test/test_eventDispatch.html
853 INFO TEST-PASS | /tests/dom/workers/test/test_eventDispatch.html | Got correct data.
854 INFO TEST-PASS | /tests/dom/workers/test/test_eventDispatch.html | Got correct data.
855 INFO TEST-END | /tests/dom/workers/test/test_eventDispatch.html | finished in 65ms
856 INFO TEST-START | /tests/dom/workers/test/test_fibonacci.html
857 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/workers/test/test_fibonacci.html | Test timed out.
}
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Created attachment 692116 [details] [diff] [review]
Patch
Assignee: nobody → khuey
Status: NEW → ASSIGNED
Attachment #692116 - Flags: review?(bent.mozilla)
Attachment #692116 - Flags: review?(bent.mozilla) → review+
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
https://hg.mozilla.org/mozilla-central/rev/71759cb2a7d9
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Comment hidden (Treeherder Robot)
Comment on attachment 692116 [details] [diff] [review]
Patch

I think we should consider taking this on branches.  It fixes an intermittent orange and a bug where certain messages are lost when lots of web workers are used.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): N/A
User impact if declined: In certain situations messages to workers may be lost, potentially breaking code.
Testing completed: On m-c, code inspection.
Risk to taking this patch (and alternatives if risky): Low risk.
String or UUID changes made by this patch: None.
Attachment #692116 - Flags: approval-mozilla-beta?
Attachment #692116 - Flags: approval-mozilla-b2g18?
Attachment #692116 - Flags: approval-mozilla-aurora?
Comment hidden (Treeherder Robot)
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #19)
> [Approval Request Comment]
> Bug caused by (feature/regressing bug #): N/A

Doesn't seem like this is a recent regression given your nom, I don't see any TBPL comments here from Aurora/Beta/B2G18, and nobody has actually seen user impact. Seems like a minor issue given that.
Comment on attachment 692116 [details] [diff] [review]
Patch

Please re-nominate if you deem it necessary after responding to the last question from triage.
Attachment #692116 - Flags: approval-mozilla-beta?
Attachment #692116 - Flags: approval-mozilla-beta-
Attachment #692116 - Flags: approval-mozilla-b2g18?
Attachment #692116 - Flags: approval-mozilla-b2g18-
Attachment #692116 - Flags: approval-mozilla-aurora?
Attachment #692116 - Flags: approval-mozilla-aurora-
Component: DOM: Mozilla Extensions → DOM
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.