Closed Bug 820556 Opened 8 years ago Closed 8 years ago

gfx code in Fennec has some cruft

Categories

(Firefox for Android :: Toolbar, defect)

ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 20
Tracking Status
firefox19 --- fixed
firefox20 --- fixed

People

(Reporter: kats, Assigned: kats)

Details

Attachments

(3 files)

cruft should die with fire.
Attached patch cruft the firstSplinter Review
mUsesDefaultProgram is always true
Attachment #691049 - Flags: review?(snorp)
Comment on attachment 691049 [details] [diff] [review]
cruft the first

Good catch, thanks
Attachment #691049 - Flags: review?(snorp) → review+
Attached patch cruft the secondSplinter Review
this code hasn't been needed since bug 727352
Attachment #691051 - Flags: review?(snorp)
Attached patch cruft the thirdSplinter Review
unused since bug 814437
Attachment #691052 - Flags: review?(snorp)
Attachment #691051 - Flags: review?(snorp) → review+
Attachment #691052 - Flags: review?(snorp) → review+
Comment on attachment 691051 [details] [diff] [review]
cruft the second

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 727352 is the one that made this code turn into cruft
User impact if declined: harder to rebase and uplift bug 817134. That's the only reason I want to uplift this.
Testing completed (on m-c, etc.): on m-c and nightlies (FF20), try run with it pushed on FF19 as well.
Risk to taking this patch (and alternatives if risky): low-risk; the code is dead and the patch isn't that large. android only.
String or UUID changes made by this patch: none
Attachment #691051 - Flags: approval-mozilla-beta?
Comment on attachment 691051 [details] [diff] [review]
cruft the second

Approving to limit risk to uplifting bug 817134, which is being uplifted in support of fixing top crasher bug 817514. Added bonus of keeping our repos in sync for future changes.
Attachment #691051 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.