Last Comment Bug 820574 - Please create approval-mozilla-b2g18, status-b2g18, tracking-b2g18, and blocking-b2g flags
: Please create approval-mozilla-b2g18, status-b2g18, tracking-b2g18, and block...
Status: RESOLVED FIXED
:
Product: bugzilla.mozilla.org
Classification: Other
Component: Administration (show other bugs)
: Production
: All All
: -- normal (vote)
: ---
Assigned To: Byron Jones ‹:glob› [PTO until 2017-01-09]
:
:
Mentors:
Depends on: 822897
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-11 13:59 PST by Alex Keybl [:akeybl]
Modified: 2013-01-14 10:53 PST (History)
10 users (show)
See Also:
Due Date:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Alex Keybl [:akeybl] 2012-12-11 13:59:30 PST
approval-mozilla-b2g18:
* Patch flag, similar to approval-mozilla-beta
* ?/+/-
* Available everywhere approval-mozilla-beta is available
* Anybody who has blocking-basecamp+/- abilities should be able to set +/-

status-b2g18:
* Tracking flag, similar to status-firefox-esr17
* unaffected, affected, fixed, wontfix, verified, disabled, verified disabled
* Available everywhere status-firefox-esr17 is available

tracking-b2g18:
* Tracking flag, similar to tracking-firefox-esr17
* ?/+/-/19+/20+/21+/22+/23+/24+
* Available everywhere tracking-firefox-esr17 is available
* Anybody who has blocking-basecamp+/- abilities should be able to set +/-/19+/...

blocking-b2g:
* Project flag, similar to blocking-basecamp
* shira?, shira+, tef?, tef+, -
* Available everywhere blocking-basecamp is available
* Anybody who has blocking-basecamp+/- abilities should be able to set shira+/tef+/-
Comment 1 Alex Keybl [:akeybl] 2012-12-11 16:24:15 PST
(In reply to Alex Keybl [:akeybl] from comment #0)
> approval-mozilla-b2g18:
> * Patch flag, similar to approval-mozilla-beta
> * ?/+/-
> * Available everywhere approval-mozilla-beta is available
> * Anybody who has blocking-basecamp+/- abilities should be able to set +/-

When ? is set on the patch flag, please paste in the following form:

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky): 
String or UUID changes made by this patch:
Comment 2 Byron Jones ‹:glob› [PTO until 2017-01-09] 2012-12-12 09:49:49 PST
The flag type approval-mozilla-b2g18 has been created.

the status, tracking and blocking flags all require schema and code changes, so these will have to happen outside peak times.

i can add these fields late tonight, and get the code pushed tomorrow night.
Comment 3 Alex Keybl [:akeybl] 2012-12-12 10:38:09 PST
(In reply to Byron Jones ‹:glob› from comment #2)
> The flag type approval-mozilla-b2g18 has been created.
> 
> the status, tracking and blocking flags all require schema and code changes,
> so these will have to happen outside peak times.
> 
> i can add these fields late tonight, and get the code pushed tomorrow night.

Thanks glob. We'll use [status-b2g18:fixed] in the meantime, and move these over to the status flag once resolved.
Comment 4 Byron Jones ‹:glob› [PTO until 2017-01-09] 2012-12-12 19:19:37 PST
Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.0/
modified extensions/BMO/lib/Data.pm
Committed revision 8420.

Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.2/
modified extensions/BMO/lib/Data.pm
Committed revision 8460.
Comment 5 Byron Jones ‹:glob› [PTO until 2017-01-09] 2012-12-13 14:45:53 PST
this fix makes us treat all values ending in ? as requests, instead of just "?".

Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.0/
modified extensions/BMO/Extension.pm
Committed revision 8421.

Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.2/
modified extensions/BMO/Extension.pm
Committed revision 8461.
Comment 6 Byron Jones ‹:glob› [PTO until 2017-01-09] 2012-12-13 18:42:54 PST
and we're live.
Comment 7 Alex Keybl [:akeybl] 2012-12-14 10:00:33 PST
Thanks for taking care of this glob.

One issue - it looks like status-b2g18 was live yesterday from the history in bug 815142, but I can't seem to find the flag now. Re-opening.
Comment 8 David Lawrence [:dkl] 2012-12-14 10:28:33 PST
Sorry we had to temporarily disable the status-b2g18 momentarily while we work out an issue with BMO that occurred around the same time the new field was commissioned. For more detail see bug 821640. As soon as we have the issue resolved we will turn the field back on.

dkl
Comment 9 Byron Jones ‹:glob› [PTO until 2017-01-09] 2013-01-14 10:53:21 PST
the issue was resolved a while back, closing.

Note You need to log in before you can comment on or make changes to this bug.