Closed Bug 820802 Opened 7 years ago Closed 3 years ago

Intermittent test_battery_status_not_charging.js, test_battery_status_unknown.js, test_battery_status_full.js, test_battery_status_discharging.js | ScriptTimeoutException: timed out

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: emorley, Unassigned)

References

Details

(Keywords: intermittent-failure)

b2g_ics_armv7a_gecko_emulator mozilla-inbound opt test marionette-webapi on 2012-12-10 23:02:18 PST for push b3968901d047

slave: talos-r3-fed-068

https://tbpl.mozilla.org/php/getParsedLog.php?id=17810448&tree=Mozilla-Inbound

{
23:08:24     INFO -  TEST-START test_battery_status_not_charging.js
23:08:35     INFO -  /home/cltbld/talos-slave/test/build/tests/marionette/tests/dom/battery/test/marionette/test_battery_status_not_charging.js, runTest (marionette_test.MarionetteJSTestCase) ... ERROR
23:08:36     INFO -  ======================================================================
23:08:36     INFO -  ERROR: /home/cltbld/talos-slave/test/build/tests/marionette/tests/dom/battery/test/marionette/test_battery_status_not_charging.js, runTest (marionette_test.MarionetteJSTestCase)
23:08:36     INFO -  ----------------------------------------------------------------------
23:08:36    ERROR -  Traceback (most recent call last):
23:08:36     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette_test.py", line 209, in runTest
23:08:36     INFO -      results = self.marionette.execute_js_script(js, args, special_powers=True)
23:08:36     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 434, in execute_js_script
23:08:36     INFO -      specialPowers=special_powers)
23:08:36     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 211, in _send_message
23:08:36     INFO -      self._handle_error(response)
23:08:36     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 260, in _handle_error
23:08:36    ERROR -      raise ScriptTimeoutException(message=message, status=status, stacktrace=stacktrace)
23:08:36    ERROR -  TEST-UNEXPECTED-FAIL | test_battery_status_not_charging.js | ScriptTimeoutException: timed out
23:08:36     INFO -  ----------------------------------------------------------------------
23:08:36     INFO -  Ran 1 test in 11.168s
23:08:36    ERROR -  FAILED (errors=1)
23:08:36     INFO -  TEST-START test_battery_status_unknown.js
23:08:46     INFO -  /home/cltbld/talos-slave/test/build/tests/marionette/tests/dom/battery/test/marionette/test_battery_status_unknown.js, runTest (marionette_test.MarionetteJSTestCase) ... ERROR
23:08:46     INFO -  ======================================================================
23:08:46     INFO -  ERROR: /home/cltbld/talos-slave/test/build/tests/marionette/tests/dom/battery/test/marionette/test_battery_status_unknown.js, runTest (marionette_test.MarionetteJSTestCase)
23:08:46     INFO -  ----------------------------------------------------------------------
23:08:46    ERROR -  Traceback (most recent call last):
23:08:46     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette_test.py", line 209, in runTest
23:08:46     INFO -      results = self.marionette.execute_js_script(js, args, special_powers=True)
23:08:46     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 434, in execute_js_script
23:08:46     INFO -      specialPowers=special_powers)
23:08:46     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 211, in _send_message
23:08:46     INFO -      self._handle_error(response)
23:08:46     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 260, in _handle_error
23:08:46    ERROR -      raise ScriptTimeoutException(message=message, status=status, stacktrace=stacktrace)
23:08:46    ERROR -  TEST-UNEXPECTED-FAIL | test_battery_status_unknown.js | ScriptTimeoutException: timed out
23:08:46     INFO -  ----------------------------------------------------------------------
23:08:46     INFO -  Ran 1 test in 10.947s
23:08:46    ERROR -  FAILED (errors=1)
23:08:46     INFO -  TEST-START test_incoming.js
23:08:48     INFO -  /home/cltbld/talos-slave/test/build/tests/marionette/tests/dom/sms/tests/marionette/test_incoming.js, runTest (marionette_test.MarionetteJSTestCase) ... ERROR
23:08:48     INFO -  ======================================================================
23:08:48     INFO -  ERROR: /home/cltbld/talos-slave/test/build/tests/marionette/tests/dom/sms/tests/marionette/test_incoming.js, runTest (marionette_test.MarionetteJSTestCase)
23:08:48     INFO -  ----------------------------------------------------------------------
23:08:48    ERROR -  Traceback (most recent call last):
23:08:48     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette_test.py", line 209, in runTest
23:08:48     INFO -      results = self.marionette.execute_js_script(js, args, special_powers=True)
23:08:48     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 434, in execute_js_script
23:08:48     INFO -      specialPowers=special_powers)
23:08:48     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 211, in _send_message
23:08:48     INFO -      self._handle_error(response)
23:08:48     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 268, in _handle_error
23:08:48     INFO -      raise MarionetteException(message=message, status=status, stacktrace=stacktrace)
23:08:48     INFO -  TEST-UNEXPECTED-FAIL | test_incoming.js | MarionetteException: Emulator callback still pending when finish() called
}
Duplicate of this bug: 822030
Summary: Intermittent test_battery_status_not_charging.js, test_battery_status_unknown.js | ScriptTimeoutException: timed out → Intermittent test_battery_status_not_charging.js, test_battery_status_unknown.js, test_battery_status_full.js, test_battery_status_discharging.js | ScriptTimeoutException: timed out
I have a theory that this and other bugs that appeared after bug 821563 landed are caused by some problem in an earlier telephony test.  I'm going to run a few things through try (and retrigger a bunch of times) to see if that holds up.
Blocks: 821563
Test disabling the four earlier telephony tests:  https://tbpl.mozilla.org/?tree=Try&rev=921e42ff9bd5
(In reply to Jonathan Griffin (:jgriffin) from comment #19)
> Test disabling the four earlier telephony tests: 
> https://tbpl.mozilla.org/?tree=Try&rev=921e42ff9bd5

I've bumped the Try job priority of these, since they are still pending (and it would really help on inbound to have this orange reduced).
Blocks: 823076
btw, I'm still waiting for a bunch of retriggers in a try run at https://tbpl.mozilla.org/?tree=Try&rev=921e42ff9bd5; depending on how this looks I'll either disable the battery tests or some telephony tests which may be causing these failures.
Disabling the battery tests on the try run at https://tbpl.mozilla.org/?tree=Try&rev=9210cc6d9d54 caused an orange to appear on a later test that we haven't seen.  This re-inforces my idea that these failures are caused by execution of an earlier telephony test.  I'm trying my idea out on cedar by disabling several of those: https://tbpl.mozilla.org/?tree=Cedar&noignore=1&rev=20f6e5eecf9e
(In reply to Jonathan Griffin (:jgriffin) from comment #78)
> Disabling the battery tests on the try run at
> https://tbpl.mozilla.org/?tree=Try&rev=9210cc6d9d54 caused an orange to
> appear on a later test that we haven't seen.  This re-inforces my idea that
> these failures are caused by execution of an earlier telephony test.  I'm
> trying my idea out on cedar by disabling several of those:
> https://tbpl.mozilla.org/?tree=Cedar&noignore=1&rev=20f6e5eecf9e

The try runs plus the retriggers on cedar seem to bear this out; I will go ahead and disable a few more telephony tests on inbound/central to see if this fixes these battery test errors.
https://hg.mozilla.org/integration/mozilla-inbound/rev/8648a92def42

I explicitly won't land this on b2g18 since this issue isn't happening there.
Whiteboard: [leave open]
Closing as it is B2G
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
Whiteboard: [leave open]
You need to log in before you can comment on or make changes to this bug.