incorrect email view with Cyrillic characters

RESOLVED DUPLICATE of bug 714724

Status

()

Bugzilla
Email Notifications
RESOLVED DUPLICATE of bug 714724
5 years ago
4 years ago

People

(Reporter: Brilliantov Kirill, Unassigned)

Tracking

Details

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
Created attachment 691317 [details]
e-mail screenshot

I use revision 8511, system configured on use UTF-8 in all text, as e-mail client I use Icedove 3.1.16 (Debian fork Thunderbird).
Unfortunally text letters look very "crooked", if I try use HTML-format - I not see content in e-mail client, change format "Image Body as" not solved problem.

Information about system:
* This is Bugzilla 4.5 on perl 5.10.1
* Running on Linux 2.6.32-5-amd64 #1 SMP Sun Sep 23 10:07:46 UTC 2012

Checking perl modules...
Checking for               CGI.pm (v3.51)     ok: found v3.63 
Checking for           Digest-SHA (any)       ok: found v5.47 
Checking for             TimeDate (v2.23)     ok: found v2.24 
Checking for             DateTime (v0.28)     ok: found v0.61 
Checking for    DateTime-TimeZone (v0.71)     ok: found v1.20 
Checking for                  DBI (v1.54)     ok: found v1.612 
Checking for     Template-Toolkit (v2.24)     ok: found v2.24 
Checking for           Email-Send (v2.04)     ok: found v2.198 
Checking for           Email-MIME (v1.904)    ok: found v1.911 
Checking for                  URI (v1.37)     ok: found v1.54 
Checking for       List-MoreUtils (v0.22)     ok: found v0.25_02 
Checking for    Math-Random-ISAAC (v1.0.1)    ok: found v1.001 

Checking available perl DBD modules...
Checking for               DBD-Pg (v2.7.0)    ok: found v2.19.3 
Checking for            DBD-mysql (v4.001)    not found 
Checking for           DBD-SQLite (v1.29)     not found 
Checking for           DBD-Oracle (v1.19)     not found 

The following Perl modules are optional:
Checking for                   GD (v1.20)     ok: found v2.39 
Checking for                Chart (v2.1)      ok: found v2.4.1 
Checking for          Template-GD (any)       not found 
Checking for           GDTextUtil (any)       not found 
Checking for              GDGraph (any)       not found 
Checking for           MIME-tools (v5.406)    not found 
Checking for          libwww-perl (any)       ok: found v5.835 
Checking for             XML-Twig (any)       not found 
Checking for          PatchReader (v0.9.6)    not found 
Checking for            perl-ldap (any)       not found 
Checking for          Authen-SASL (any)       not found 
Checking for         Net-SMTP-SSL (v1.01)     not found 
Checking for           RadiusPerl (any)       not found 
Checking for            SOAP-Lite (v0.712)    not found 
Checking for             JSON-RPC (any)       not found 
Checking for              JSON-XS (v2.0)      not found 
Checking for           Test-Taint (v1.06)     not found 
Checking for          HTML-Parser (v3.40)     ok: found v3.66 
Checking for        HTML-Scrubber (any)       not found 
Checking for               Encode (v2.21)     ok: found v2.35 
Checking for        Encode-Detect (any)       not found 
Checking for          Email-Reply (any)       not found 
Checking for HTML-FormatText-WithLinks (v0.13)     not found 
Checking for          TheSchwartz (any)       not found 
Checking for       Daemon-Generic (any)       not found 
Checking for             mod_perl (v1.999022) not found 
Checking for     Apache-SizeLimit (v0.96)     not found 
Checking for        File-MimeInfo (any)       not found 
Checking for           IO-stringy (any)       ok: found v2.110 
Checking for          mod_headers (any)       not found 
Checking for          mod_expires (any)       not found 
Checking for              mod_env (any)       ok

Thank you and excuse me my bad english.

Comment 1

5 years ago
Is it shown correctly in a modern email client?
(Reporter)

Comment 2

5 years ago
Created attachment 691689 [details] [diff] [review]
HTML mail different
(Reporter)

Comment 3

5 years ago
Created attachment 691690 [details] [diff] [review]
TXT mail different
(Reporter)

Comment 4

5 years ago
Yes, it correct.
I think I found possible reason - I add cyrillic interface, unfortunally it very old, for version 4.2.4.
I add different beetwen bugmail.txt.tmpl and bugmail.html.tmpl.
(Reporter)

Comment 5

5 years ago
I change directory template/ru-RU/default/email on template/en/default/email, unfortunally this is not solve problem.

Comment 6

5 years ago
1) Is it shown correctly in a modern email client?
2) Please attach an example email received.
Flags: needinfo?(brilliantov)
(Reporter)

Comment 7

5 years ago
Created attachment 691751 [details]
TXT email

example TXT e-mail
Flags: needinfo?(brilliantov)

Updated

4 years ago
Summary: incorrect email view with cirillic data → incorrect email view with Cyrillic characters

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 714724
You need to log in before you can comment on or make changes to this bug.