Textarea's rendered twice when inline JS used

RESOLVED DUPLICATE of bug 73331

Status

()

RESOLVED DUPLICATE of bug 73331
18 years ago
18 years ago

People

(Reporter: mozbugzilla, Assigned: karnaze)

Tracking

({testcase})

Trunk
x86
Windows 98
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Build ID: 2001051804 and other recent nightlies.

When viewing the (soon to be attached) test case, the TEXTAREA is rendered
twice, one below the other.  Clicking the top textarea causes the bottom one to
be selected.  Editing in the bottom textarea is broken - the backspace key
doesn't work, the enter key doesn't insert new lines and wordwrapping does not
occur.

This problem is somehow related to the inline JavaScript in the test case.  If
it is removed, the problem doesn't occur.  In addition, closing the paragraph
element _after_ that containing the TEXTAREA stops the problem occurring.

This problem does not occur in Mozilla 0.9.

Sorry to use browser-general, but I really couldn't work out which particular
area this one belongs to.
(Reporter)

Comment 1

18 years ago
Created attachment 35563 [details]
Test case for 82083
yeah... and try using a selectbox instead of a textarea, it'll jump downwards
when you select the >1st option. I guess it might be the same problem behind
that one too. bug 81605 looks pretty much like the same kinda stuff to me.

Comment 3

18 years ago
updating component.
Assignee: asa → rods
Status: UNCONFIRMED → NEW
Component: Browser-General → HTML Form Controls
Ever confirmed: true
Keywords: testcase
QA Contact: doronr → vladimire

Comment 4

18 years ago
reassigning
Assignee: rods → beppe

Comment 5

18 years ago
not sure why this is an editor issue, reassign to layout where it should have 
been reassigned to
Assignee: beppe → karnaze
Component: HTML Form Controls → Layout
QA Contact: vladimire → petersen

Comment 6

18 years ago
Hmm I dont think I see the bug. How can you tell if there is one or two text 
areas if they are on top of eachother?
(Reporter)

Comment 7

18 years ago
They are rendered with one significantly lower down the page than the other.  I 
did not mean "overlapping" when I said "below".  If the bug occurs, you would 
know about it!  From things I've noticed recently, the bug may actually have 
been fixed.  However, I haven't been able to definitely confirm this yet.
(Reporter)

Comment 8

18 years ago
NOT FIXED!

No, I can now confirm that this bug has NOT been fixed as of Build 2001051804 
on Intel Win32.  The text area is clearly rendered twice as if there were two, 
one vertically below the other on the page.  All previously described behaviour 
still occurs.

Comment 9

18 years ago
on winMe using 2001061808 the testcase works fine for me
however since the behaviour seems identical to 73331 im going to dup this bug
against it

*** This bug has been marked as a duplicate of 73331 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.