Last Comment Bug 820833 - "No memory card found" in gaia apps on pandaboard
: "No memory card found" in gaia apps on pandaboard
Status: RESOLVED WONTFIX
QARegressExclude
:
Product: Core
Classification: Components
Component: Widget: Gonk (show other bugs)
: Trunk
: x86 Gonk (Firefox OS)
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 821357
Blocks: b2g-testing-track
  Show dependency treegraph
 
Reported: 2012-12-12 07:14 PST by Malini Das [:mdas] - Away, not checking bugmail
Modified: 2016-03-21 08:47 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Malini Das [:mdas] - Away, not checking bugmail 2012-12-12 07:14:53 PST
When running b2g on the pandaboard, it seems the sdcard may not have all the right pieces in place for it to be used as external memory. If you launch the 'music' or 'gallery' app in gaia, it will complain about no memory card being found, even if I push files to /sdcard and /mnt/sdcard.

How can we make space available? This is needed for gaia smoketest automation.
Comment 1 Armen Zambrano [:armenzg] (EDT/UTC-4) 2012-12-12 07:39:18 PST
Adding dividehex in case he has an idea from the IT side to make this happen.

Is this related to Gaia UI tests at all? (bug 802317)
Comment 2 Jonathan Griffin (:jgriffin) 2012-12-12 13:51:25 PST
Yes, this is related to gaia ui tests (bug 802317), but only will block specific tests, not the entire suite.
Comment 3 Malini Das [:mdas] - Away, not checking bugmail 2012-12-13 09:54:50 PST
I caught up with dhylands about sdcard partitions, and by default, there is no volume configuration for the sdcard. There should be a vold.fstab file in /system/etc/ describing what to mount. I tried fiddling about with different configs, but to no avail.

Dhylands has filed a bug to get this resolved: Bug 821357
Comment 4 John O'Duinn [:joduinn] (please use "needinfo?" flag) 2013-01-09 12:30:20 PST
mdas/jgriffin/dhyland: its been a while since update in this bug - can you give progress/status?
Comment 5 Malini Das [:mdas] - Away, not checking bugmail 2013-01-09 15:39:09 PST
AFAIK, there has been no progress, and Bug 821357 has not been updated :/
Comment 6 Armen Zambrano [:armenzg] (EDT/UTC-4) 2013-01-21 14:02:24 PST
mdas, should this still block bug 802317?

Can I assume that it does not prevent us from greening the gaia UI tests? (we currently only have the calendar test failing)
Comment 7 Malini Das [:mdas] - Away, not checking bugmail 2013-01-22 12:49:46 PST
It prevents us from running the music and video related gaia UI tests. We're greening the tests by removing these from the list of tests we run, so if we had access then we can run more gaia UI tests.
Comment 8 Jake Watkins [:dividehex] 2013-01-22 13:09:45 PST
There is a fat32 partition (/dev/sda6) on the panda board which is utilized by the android panda image as /sdcard.  Is there a reason this isn't be used for B2G on pandaboards?
Comment 9 Malini Das [:mdas] - Away, not checking bugmail 2013-01-22 14:09:37 PST
(In reply to Jake Watkins [:dividehex] from comment #8)
> There is a fat32 partition (/dev/sda6) on the panda board which is utilized
> by the android panda image as /sdcard.  Is there a reason this isn't be used
> for B2G on pandaboards?

That's a question that's better targetted at dhylands on bug 821357 :)
Comment 10 Justin Wood (:Callek) (Away until Aug 29) 2016-03-21 08:47:09 PDT
No longer using pandas at mozilla

Note You need to log in before you can comment on or make changes to this bug.