evernote.com serves simplified mobile interface to B2G

RESOLVED FIXED

Status

Tech Evangelism
Mobile
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: nwgh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [country-all] [sitewait] [serversniff], URL)

Attachments

(2 attachments)

Created attachment 691507 [details]
evernote mobile on b2g with simplified interface

While trying to dogfood my B2G device, I realized that I was sorely missing Evernote. So, I hit up their mobile website and was kind of appalled at how bad it was. Thinking this might be a sniffing issue, I tested using Fennec on my Android device, and the experience (while still not what I'd hoped it would be) was way better than on B2G. I used the Phony extension on my Android and set the UA to be that of FirefoxOS, and was served with the simplified interface just like on the B2G device, so this definitely seems to be a case of UA sniffing gone wrong. We should probably reach out to them. Screenshots attached.
Created attachment 691508 [details]
evernote mobile on firefox for android with more modern interface

Note titles and contents blurred to protect the innocent :)
Summary: Evernote serves simplified mobile interface to B2G → evernote.com serves simplified mobile interface to B2G
Seems they are focused on their apps at the moment.. Here's how their mobile website works for me (or not):

1) Load evernote.com/m in Android stock browser -> Plain text page with obvious links to app downloads, easy to miss "sign in" link. Tapping the sign in link takes me to a 404 page..
 (Loading evernote.com gives me a blank page with no content appearing, although looking at the HTTP traffic it does actually download the stuff required to render the desktop page)

2) In Firefox on Android: ditto. Same as stock browser, except that if you go to "evernote.com" the desktop page actually appears.

3) In Firefox OS: almost same, except that on the evernote.com/m page there is no "sign in" link at all..
What's up with the mobile site?
Flags: needinfo?(alex+ffbugz)

Updated

4 years ago
Whiteboard: [country-all] [sitewait] [serversniff]

Comment 4

4 years ago
So tested today.

* On Firefox for Android I get a nice Mobile content Web site. Maybe responsive and we stay on www.evernote.com. Could someone check after login.

* On Firefox OS ZTE device 1.2, The site never finishes loading, which is a bit weird.

* On emulating Firefox OS UA on desktop, and resizing to a small browser window. I receive the nice layout I see on Firefox for Android.

Hallvord could you check if there's something higher up which is not working well.
Flags: needinfo?(hsteen)
The "good" news: I can reproduce the problem - evernote.com never finishes loading on a Geeksphone Peak. It does get far enough to get the <title> of the site recorded in history, but then it hangs.

The bad news: I still haven't found a way to debug this problem.

* Spoofing desktop as FxOS: works fine
* Emulator: works fine
* Firefox on Android: works fine
* Editing hosts file on Geeksphone to use Fiddler as a proxy: changes behaviour, it now stops loading (however, the request doesn't show up in Fiddler..?!?)

Still working on this..
(Also tested Firefox on Android *spoofing as* Firefox OS.)
Tested on Tarako device - it does finish loading here (it takes a while! No idea why..). We get the same version as Firefox on Android and the Android stock browser gets. Main page looks adaptive and fits the screen quite well, subsequent pages look a bit more desktop-ish, but this happens in all mobile browsers I tested.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(hsteen)
Flags: needinfo?(alex+ffbugz)
Resolution: --- → FIXED
Hm.. I didn't test http://evernote.com/m/ - only http://evernote.com . 

So there are three sites/versions

http://evernote.com - nice, adaptive desktop site, readable until you click through to sub-pages

http://evernote.com/m/ no login form - just some text and a link to download apps.

http://www.evernote.com/m/ - this URL has a login form (!) and it serves a more simplified version to Firefox OS. So this problem is still there while the "doesn't stop loading" issue is gone for me.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 9

4 years ago
This seems to be fixed.
When entering evernote.com we are receiving the responsive site, The menu is working and when we select the 3 rows menu, we can sign in.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.