Contacts: Fix phonenumberJS error

RESOLVED FIXED in Firefox 19

Status

()

Core
DOM: Device Interfaces
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: gwagner, Assigned: gwagner)

Tracking

unspecified
mozilla20
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(blocking-basecamp:+, firefox19 fixed, firefox20 fixed, b2g18 fixed)

Details

Attachments

(1 attachment)

1.30 KB, patch
Ben Turner (not reading bugmail, use the needinfo flag!)
: review+
Details | Diff | Splinter Review
(Assignee)

Description

5 years ago
Created attachment 691582 [details] [diff] [review]
patch
Attachment #691582 - Flags: review?(bent.mozilla)
Comment on attachment 691582 [details] [diff] [review]
patch

Review of attachment 691582 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/contacts/fallback/ContactDB.jsm
@@ +270,5 @@
>                    debug("InternationalFormat: " + parsedNumber.internationalFormat);
>                    debug("InternationalNumber: " + parsedNumber.internationalNumber);
>                    debug("NationalNumber: " + parsedNumber.nationalNumber);
>                    debug("NationalFormat: " + parsedNumber.nationalFormat);
> +                  if (parsedNumber.internationalNumber && number.toString() !== parsedNumber.internationalNumber) {

Nit: I'd split this to two lines ;)
Attachment #691582 - Flags: review?(bent.mozilla) → review+
(Assignee)

Comment 2

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/4dbff6dc7b50
blocking-basecamp: --- → ?
(Assignee)

Updated

5 years ago
Duplicate of this bug: 820843

Comment 4

5 years ago
https://hg.mozilla.org/mozilla-central/rev/4dbff6dc7b50
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Comment on attachment 691582 [details] [diff] [review]
patch

[Triage Comment]
Attachment #691582 - Flags: approval-mozilla-b2g18+
Attachment #691582 - Flags: approval-mozilla-aurora+
Not blocking on this since no motivation was given why this bug is important. Feel free to renom with a motivation, or just uplift the patch since I just a+'ed it.
blocking-basecamp: ? → -
(Assignee)

Comment 7

5 years ago
It can cause an Error in our ContactsDB code during importing or saving contacts and we never return from the request.
So it's impossible to save a contact or import contacts from the SIM card. 
Already seen in bug 820843.

E/GeckoConsole(  674): [JavaScript Error: "(intermediate value).internationalNumber is null" {file: "resource://gre/modules/ContactDB.jsm" line: 275}]
blocking-basecamp: - → ?
blocking-basecamp: ? → +
https://hg.mozilla.org/releases/mozilla-aurora/rev/39fc83f65037
https://hg.mozilla.org/releases/mozilla-b2g18/rev/eda5f62ab373
status-b2g18: --- → fixed
status-firefox19: --- → fixed
status-firefox20: --- → fixed
Blocks: 833706
You need to log in before you can comment on or make changes to this bug.