PBM - Search suggestion text illegible

VERIFIED FIXED in Firefox 20

Status

()

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: aaronmt, Assigned: sriram)

Tracking

20 Branch
Firefox 20
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox20 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 691822 [details]
Nightly (12/13) - Screenshot

Not sure if another theming bug already will cover this or not; see screenshot.

--
Nightly (12/13)
Sriram - Is this a dupe of the Persona text bug, or is it different?
Assignee: nobody → sriram
(Assignee)

Comment 2

6 years ago
Created attachment 692053 [details] [diff] [review]
Patch

Changed the TextView to GeckoTextView and set the private mode when inflated.
Attachment #692053 - Flags: review?(bnicholson)
Comment on attachment 692053 [details] [diff] [review]
Patch

Review of attachment 692053 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/base/awesomebar/AllPagesTab.java
@@ +602,5 @@
> +        GeckoTextView promptText = (GeckoTextView) mSuggestionsOptInPrompt.findViewById(R.id.suggestions_prompt_title);
> +        promptText.setText(getResources().getString(R.string.suggestions_prompt, mSearchEngines.get(0).name));
> +
> +        Tab tab = Tabs.getInstance().getSelectedTab();
> +        if (tab != null && tab.isPrivate())

I hate these superfluous null checks...we should maybe try a Try push without them since Talos no longer does session restores (which I believe is why you needed to add these checks to begin with).
Attachment #692053 - Flags: review?(bnicholson) → review+

Comment 6

6 years ago
https://hg.mozilla.org/mozilla-central/rev/e1a57065f541
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20

Comment 7

6 years ago
Firefox 20.0a1 (2012-11-19)
Device: Galaxy Nexus
OS: Android 4.1.1 

This is not reproducible on latest Nightly. Marking bug as Verified Fixed.
Status: RESOLVED → VERIFIED

Updated

6 years ago
status-firefox20: affected → verified
Depends on: 826267
You need to log in before you can comment on or make changes to this bug.