Closed Bug 821401 Opened 10 years ago Closed 10 years ago

mozilla-b2g18 should build desktop b2g builds on checkin

Categories

(Release Engineering :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jhford, Assigned: aki)

References

Details

Attachments

(4 files)

This branch is limited in scope to B2G only changes.  Given the relatively high chance of someone landing on this branch and wanting to test their changes with a desktop build coupled with the relatively low volume of checkins, we should consider building the b2g desktop builds on this branch on each change.
found in triage, moving to correct component.
Component: Release Engineering → Release Engineering: Automation (General)
QA Contact: catlee
should we be building firefox at all on this branch?

or, alternatively, should we enable the per-product building logic on this branch? (e.g. only build b2g if only b2g/ changes)
(In reply to Chris AtLee [:catlee] from comment #2)
> should we be building firefox at all on this branch?
> 
> or, alternatively, should we enable the per-product building logic on this
> branch? (e.g. only build b2g if only b2g/ changes)

I asked Alex about this last week, and he said that we should.
Clarification: do you mean desktop Firefox, or desktop b2g ?
I was referring to Desktop B2G
Summary: mozilla-b2g18 should build desktop builds on checkin → mozilla-b2g18 should build desktop b2g builds on checkin
(In reply to Chris AtLee [:catlee] from comment #2)
> should we be building firefox at all on this branch?
> 
> or, alternatively, should we enable the per-product building logic on this
> branch? (e.g. only build b2g if only b2g/ changes)

a) since b2g18 is b2g-oriented, if we did this I'd say we should build b2g on all changes, and don't build firefox if the change is only in b2g/.

b) since this bug is desktop b2g specific, this is a question outside the scope of this bug :)
Attachment #692038 - Flags: review?(catlee) → review+
Attachment #692039 - Flags: review?(catlee) → review+
Assignee: nobody → aki
In production.
These are getting a --config-file None for the multilocale portion.
Hidden, need to fix.
This adds the multilocale bits to the dep kwargs, but only for b2g.
I should also investigate a solution around this that keys off of "enable_multilocale_dep" or something instead of looking at the product.

I'd like to test a dep+nightly b2g desktop build to verify both are multilocale, and a dep+nightly android build to verify only android nightlies are multilocale.
Duplicate of this bug: 821721
Comment on attachment 692130 [details] [diff] [review]
fix dep b2g desktop builds

Dep+nightly b2g linux desktop : multilocale with a proper --config-file
Nightly android: multilocale
Dep android: non-multilocale
Attachment #692130 - Flags: review?(bhearsum)
Attachment #692130 - Attachment description: [needs testing] fix dep b2g desktop builds → fix dep b2g desktop builds
Comment on attachment 692130 [details] [diff] [review]
fix dep b2g desktop builds

Review of attachment 692130 [details] [diff] [review]:
-----------------------------------------------------------------

Heh, looks very similar to the original patch that I thought wouldn't be necessary. Hooray for horrible hacks!
Attachment #692130 - Flags: review?(bhearsum) → review+
In production
Hm, the 'check' tests seem to be broken.

:bhearsum, :jhford, should we be running 'make check' for desktop b2g builds?  (hg blame tells me you two set those flags.)

If not, I can turn those off and get these builds green (currently orange on mozilla-b2g18).

If so, we need to otherwise get these builds green to unhide them.
I clobbered these builds; maybe that'll help.
Flags: needinfo?(jhford)
(In reply to Aki Sasaki [:aki] from comment #19)
> Hm, the 'check' tests seem to be broken.
> 
> :bhearsum, :jhford, should we be running 'make check' for desktop b2g
> builds?  (hg blame tells me you two set those flags.)
> 
> If not, I can turn those off and get these builds green (currently orange on
> mozilla-b2g18).
> 
> If so, we need to otherwise get these builds green to unhide them.
> I clobbered these builds; maybe that'll help.

It would be great to have the check tests run green, but I think having the builds visible is going to catch more errors than if they are hidden.
Flags: needinfo?(jhford)
Going to stage this.
Comment on attachment 693554 [details] [diff] [review]
disable b2g18 b2g desktop check tests

Sorry for all the reviews.
Kicked off a b2g linux b2g18 build in staging and verified there was no check step, and it ran green.
Attachment #693554 - Flags: review?(bhearsum)
Attachment #693554 - Flags: review?(bhearsum) → review+
These appear to be green now.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.