Last Comment Bug 821422 - Plugin block request: versions of Flip4Mac < 2.4.4
: Plugin block request: versions of Flip4Mac < 2.4.4
Status: RESOLVED FIXED
[plugin]
:
Product: Toolkit
Classification: Components
Component: Blocklisting (show other bugs)
: unspecified
: x86 Mac OS X
: -- major (vote)
: ---
Assigned To: Jorge Villalobos [:jorgev]
: juan becerra [:juanb]
Mentors:
Depends on:
Blocks: 816442
  Show dependency treegraph
 
Reported: 2012-12-13 12:03 PST by bhavana bajaj [:bajaj]
Modified: 2016-03-07 15:30 PST (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description bhavana bajaj [:bajaj] 2012-12-13 12:03:23 PST
Plugin name: Flip4Mac
Plugin versions to block: any version < Flip4Mac 2.4.4
Applications, versions, and platforms affected:
   Mac OS X 10.5 Leopard
   Mac OS X 10.6 Snow Leopard,x86, Mac OSX

Plugin name: Flip4Mac
Plugin versions to block: any version < Flip4Mac 3.0
Applications, versions, and platforms affected:
   OS X 10.7 Lion
  OS X 10.8 Mountain Lion ,x86, Mac OSX


Block severity: (hard/soft)

How does this plugin appear in about:plugins? (QA(juanb) to help with these details)
    File: 
    Version: 
    Description: 

Homepage and other references and contact info:http://www.telestream.net/flip4mac/overview.htm 

Reasons:This is #1 crasher in FF18 for Mac OSX (more details : Bug 816442 ).
Please note the block needs to apply only for FF18 .
Comment 1 juan becerra [:juanb] 2012-12-13 16:25:32 PST
3.0.0.126 (latest version advertised as compatible with 10.7 and 10.8):

Flip4Mac Windows Media Plugin
    File: Flip4Mac WMV Plugin.plugin
    Version: 2.5.0.1
    The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.

2.4.4.2 (latest version advertised as compatible with 10.5 and 10.6):

Flip4Mac Windows Media Plugin
    File: Flip4Mac WMV Plugin.plugin
    Version: 2.4.4.2
    The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.

Random old installer:

Flip4Mac Windows Media Plugin 2.3.6
    File: Flip4Mac WMV Plugin.plugin
    Version: 2.3.6.5
    The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.

Older version designations found in http://osx.iusethis.com/app/versions/6206 but most download links do not work.
Comment 2 Jorge Villalobos [:jorgev] 2012-12-13 16:57:55 PST
We can't block plugins by OS version, so we can't make the distinction between 10.6 and 10.7. I think Alex mentioned that it was unnecessary because of the Mac OS versions we support on 18 and above, but it'd be good to confirm this.

So, we want to block everything saying "Flip4Mac" in the description, correct?
Comment 3 Scoobidiver (away) 2012-12-14 01:01:30 PST
(In reply to Jorge Villalobos [:jorgev] from comment #2)
> So, we want to block everything saying "Flip4Mac" in the description,
> correct?
We want to blocklist all versions of Flip4Mac except the latest ones, that is 2.4.4 on Mac OS X 10.6 and 3.0.0 on Mac OS X 10.7/10.8 (we don't know the cutoff version so don't take into account the fourth figure in comment 1).

> We can't block plugins by OS version
Let's try all versions strictly lower than 2.4.4 on Firefox 18 and above to see how things work.
Comment 4 Alex Keybl [:akeybl] 2012-12-14 09:56:21 PST
(In reply to Jorge Villalobos [:jorgev] from comment #2)
> We can't block plugins by OS version, so we can't make the distinction
> between 10.6 and 10.7. I think Alex mentioned that it was unnecessary
> because of the Mac OS versions we support on 18 and above, but it'd be good
> to confirm this.

Making this Mac version specific shouldn't be a problem. Their supported versions of Mac OS X on the latest F4M versions is a superset of ours.
Comment 5 Jorge Villalobos [:jorgev] 2012-12-17 14:01:38 PST
Staged: https://addons-dev.allizom.org/en-US/firefox/blocked/p235
Comment 6 Alex Keybl [:akeybl] 2012-12-19 14:07:36 PST
Let's try to get this staged block tested and pushed to production before the end of the week, so that we can be certain it helps bug 816442 ahead of our final beta.
Comment 7 juan becerra [:juanb] 2012-12-21 10:45:20 PST
This is working as expected in staging. I was able to find and install an older 2.x version and it gets blocked.

However this blocklist will work for older 2.4.x versions, but not for older 2.5x versions (which corresponds to Flip4mac 3.0 versions). I wasn't able to find an 3.0.x installer.

I suppose this is better than nothing, but if people have older unstable 3.0x versions those will still be enabled.

(I wasn't able to find an older 3.0x version)
Comment 8 Alex Keybl [:akeybl] 2012-12-21 13:07:39 PST
(In reply to juan becerra [:juanb] from comment #7)
> This is working as expected in staging. I was able to find and install an
> older 2.x version and it gets blocked.
> 
> However this blocklist will work for older 2.4.x versions, but not for older
> 2.5x versions (which corresponds to Flip4mac 3.0 versions). I wasn't able to
> find an 3.0.x installer.
> 
> I suppose this is better than nothing, but if people have older unstable
> 3.0x versions those will still be enabled.
> 
> (I wasn't able to find an older 3.0x version)

That should be fine - >70% of the crashes were with 10.6 (new 10.7 users probably don't take the time to install F4M anymore). Let's do what we can here.

Let's push to production whenever you all are ready.
Comment 9 Jorge Villalobos [:jorgev] 2012-12-21 13:34:03 PST
Blocked: https://addons.mozilla.org/en-US/firefox/blocked/p242
Comment 10 juan becerra [:juanb] 2012-12-26 09:19:23 PST
This was verified on production.
Comment 11 Steven Michaud [:smichaud] (Retired) 2013-01-17 09:08:44 PST
There's evidence at bug 816442 that we're not blocking enough versions of Flip4Mac.  See particularly bug 816442 comment #29 and bug 816442 comment #30.
Comment 12 Jorge Villalobos [:jorgev] 2013-01-17 09:18:07 PST
Is there no way to know exactly which versions are causing the crashing problems?
Comment 13 Steven Michaud [:smichaud] (Retired) 2013-01-17 11:00:39 PST
(In reply to comment #12)

Unfortunately not.

Telestream doesn't make old versions of Flip4Mac easily available (see bug 816442 comment #19).  And Breakpad doesn't report the actual plugin version number (only the ersatz "debug ID").  If old versions of Flip4Mac were available, we could use them to match up debug IDs with versions numbers ... but they're not.

My tests (and Breakpad information cited at bug 816442) suggest that versions 2.4.4.2 and 3.0.0.126 don't crash.  I suggest blocking all versions lower than those.
Comment 14 Robert Kaiser (not working on stability any more) 2013-01-17 14:46:51 PST
(In reply to Steven Michaud from comment #13)
> My tests (and Breakpad information cited at bug 816442) suggest that
> versions 2.4.4.2 and 3.0.0.126 don't crash.

To verify that, I could file a data request bug to hopefully pull out Socorro data that makes sure those versions don't appear in the relevant crashes.

For that, I'd need the names and debug IDs of those binaries, though, and the crash signatures to look into.

Ted, Benjamin, do we have a document somewhere that shows how we can get those debug IDs?
Comment 15 Steven Michaud [:smichaud] (Retired) 2013-01-17 15:01:56 PST
> For that, I'd need the names and debug IDs of those binaries,
> though, and the crash signatures to look into.

This information is available at bug 816442.  For the debug IDs (and
binary names) of the "working" versions of Flip4Mac, see bug 816442.

> Ted, Benjamin, do we have a document somewhere that shows how we can
> get those debug IDs?

When you do a custom build, a 'dump_syms' binary is created in
[objdir]/dist/host/bin.  Run it without any commandline parameters to
get it to display how you use it.  Run it on a binary to generate a
debug ID for that binary.

Note that a "universal" binary (e.g. a binary that contains i386 and
x86_64 architectures) will have a distinct debug ID for each of its
architectures.
Comment 16 Steven Michaud [:smichaud] (Retired) 2013-01-17 15:04:08 PST
> For the debug IDs (and binary names) of the "working" versions of
> Flip4Mac, see bug 816442.

See bug 816442 comment #17.

Note You need to log in before you can comment on or make changes to this bug.