Fix ParseNumber so that it accepts a null defaultRegion.

RESOLVED FIXED in Firefox 19

Status

defect
P1
major
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: nsarkar, Assigned: gwagner)

Tracking

unspecified
B2G C3 (12dec-1jan)
Other
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+, firefox19 fixed, firefox20 fixed, b2g18 fixed)

Details

Attachments

(1 attachment)

The ParseNumber method in PhoneNumber.jsm (http://mxr.mozilla.org/mozilla-central/source/dom/phonenumberutils/PhoneNumber.jsm#298)doesn't handle the case where defaultRegion is null.

The bug was uncovered when the mcc we were using came from the test equipment and didn't match any in the mcc table(MCC_ISO3166_TABLE). Because of that, the country code passed in here - http://mxr.mozilla.org/mozilla-central/source/dom/phonenumberutils/PhoneNumberUtils.jsm#56 is null.
In such a scenario, it is seen that import sim contacts fails and contacts are not imported.
Blocks: 808607
Status: UNCONFIRMED → NEW
Ever confirmed: true
To add to what Nivi mentioned, this is failing a GCF test case.
Assignee: nobody → anygregor
blocking-basecamp: ? → +
Target Milestone: --- → B2G C3 (12dec-1jan)
(In reply to Anshul from comment #1)
> To add to what Nivi mentioned, this is failing a GCF test case.

What is a GCF test case?
It's a device certification test suite.
Posted patch patchSplinter Review
Attachment #693202 - Flags: review?(gal)
Comment on attachment 693202 [details] [diff] [review]
patch

Make the comment a little clearer.
Attachment #693202 - Flags: review?(gal) → review+
Great bug report and diagnosis. ++nsarkar
https://hg.mozilla.org/mozilla-central/rev/79a8d91ba1cb
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Verified the fix. Works correctly now. Thanks.
You need to log in before you can comment on or make changes to this bug.