Closed Bug 821927 Opened 7 years ago Closed 7 years ago

Frequent test_redundant_operations.js | ScriptTimeoutException: timed out

Categories

(Core :: DOM: Device Interfaces, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED WORKSFORME
mozilla20

People

(Reporter: jgriffin, Unassigned)

References

Details

(Keywords: intermittent-failure)

The test dom/telephony/test/marionette/test_redundant_operations.js is frequently failing with this error:

14:56:57    ERROR -  Traceback (most recent call last):
14:56:57     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette_test.py", line 213, in runTest
14:56:57     INFO -      results = self.marionette.execute_js_script(js, args, special_powers=True)
14:56:57     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 450, in execute_js_script
14:56:57     INFO -      specialPowers=special_powers)
14:56:57     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 227, in _send_message
14:56:57     INFO -      self._handle_error(response)
14:56:57     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 276, in _handle_error
14:56:57    ERROR -      raise ScriptTimeoutException(message=message, status=status, stacktrace=stacktrace)
14:56:57    ERROR -  TEST-UNEXPECTED-FAIL | test_redundant_operations.js | ScriptTimeoutException: timed out

Sometimes, this causes mass carnage afterwards, othertimes it's just this one test that fails.

This appeared at roughly the same time on mozilla-inbound and mozilla-central, at about the same time the emulator used by buildbot was updated (bug 821563), so I'm thinking that is the cause, even though I can't reproduce it locally.

I'm going to disable this test for now, since it's failing most of the time.
Blocks: 821563
No longer depends on: 821563
https://hg.mozilla.org/mozilla-central/rev/75e1f24b9af7
Assignee: nobody → jgriffin
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee: jgriffin → nobody
Resolving WFM keyword:intermittent-failure bugs last modified >3 months ago, whose whiteboard contains none of:
{random,disabled,marked,fuzzy,todo,fails,failing,annotated,time-bomb,leave open}

There will inevitably be some false positives; for that (and the bugspam) I apologise. Filter on orangewfm.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.