Acct Central Offline Settings should go to Offline panel.

VERIFIED FIXED in mozilla0.9.3

Status

SeaMonkey
MailNews: Backend
P2
normal
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: laurel, Assigned: chuang)

Tracking

Trunk
mozilla0.9.3
x86
Other

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+]have fix)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Using may22 commercial trunk build

The Offline Settings link in the Account Central/account level page in the mail
window should land on the selected account's Offline & Disk Space panel in the
account settings dialog.  Currently it lands at the selected account level panel.
(Reporter)

Updated

17 years ago
Keywords: nsbeta1

Comment 1

17 years ago
That's right. I may have to change the way AccountManager window is opened (not 
just based on the server type like it does today) so that individual items under 
a given account can be selected. Accepting.
Status: NEW → ASSIGNED

Comment 2

17 years ago
moving to 0.9.2
Priority: -- → P2
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9.2

Comment 3

17 years ago
*** Bug 82491 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
moving to 0.9.3
Target Milestone: mozilla0.9.2 → mozilla0.9.3

Updated

17 years ago
Keywords: nsBranch

Comment 5

17 years ago
reassigning to chuang
Assignee: racham → chuang
Status: ASSIGNED → NEW

Updated

17 years ago
Keywords: nsBranch
(Assignee)

Comment 6

17 years ago
Created attachment 42238 [details] [diff] [review]
Patch for the fix
(Assignee)

Comment 7

17 years ago
Passing the page xul file name in ViewSetting() or MsgAccountManager(), we can 
select the page we want.  Passing null will open the main page for the selected 
server in folder pane.
Whiteboard: [nsbeta1+] → [nsbeta1+]have fix

Comment 8

17 years ago
Patch looks good.

Please change 
+  children = selectServer.childNodes;
to
+  var children = selectServer.childNodes;

Also, this will the good time to add comments on the top of MsgAccountManager()
in accountUtils.js explaining the param(s).

Please take care of those and run couple of tests.

r=bhuvan.

(Assignee)

Comment 9

17 years ago
Created attachment 42397 [details] [diff] [review]
New patch with added comment and 'var' declaration

Comment 10

17 years ago
sr=mscott
(Assignee)

Comment 11

17 years ago
Fix checked into trunk.
Status: NEW → ASSIGNED
(Assignee)

Comment 12

17 years ago
Mark fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 13

17 years ago
Using commercial trunk builds:
2001080203 NT 4.0
2001080208 linux 2.2
2001080208 mac 9.0.4

Verified clicking on offline settings, in account
central, will now take you to that accounts Offline and Disk Space
pref panel. Tested this on imap accounts, webmail, and newsgroups.
Tested both Modern and Classic theme also.

Marking as verified.

Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.