Last Comment Bug 821972 - Plugin block request: versions of DivX <= 7.0
: Plugin block request: versions of DivX <= 7.0
Status: RESOLVED FIXED
[plugin]
:
Product: Toolkit
Classification: Components
Component: Blocklisting (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Jorge Villalobos [:jorgev]
:
Mentors:
Depends on:
Blocks: 816445
  Show dependency treegraph
 
Reported: 2012-12-15 00:40 PST by Scoobidiver (away)
Modified: 2016-03-07 15:30 PST (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed


Attachments
DivX block UI (554.37 KB, image/png)
2012-12-19 07:34 PST, Virgil Dicu [:virgil] [QA]
no flags Details

Description Scoobidiver (away) 2012-12-15 00:40:28 PST
Plugin name: DivX
Plugin versions to block: 7.0 and below
Applications, versions, and platforms affected: Mac OS X, Firefox 18 and above
Block severity: (hard/soft)

How does this plugin appear in about:plugins?
    File: 
    Version: 
    Description: 

Homepage and other references and contact info: http://www.divx.com/en/software/divx-plus

Reasons: bug 816445
Comment 1 Jorge Villalobos [:jorgev] 2012-12-17 08:23:32 PST
Bug 816445 comment #15 claims these are very old versions of the DivX plugin, so I don't have any objections if that's correct.

Do we support the DivX plugin in the plugin check page?
Comment 2 Alex Keybl [:akeybl] 2012-12-18 11:55:54 PST
Virgil can help test the plugin check page with Divx, but I wouldnt' block on that given the volume of crashes.
Comment 3 Jorge Villalobos [:jorgev] 2012-12-18 12:45:23 PST
Can someone give me the about:plugins information for this plugin? What I have on my machine is DivX Web Player (DivXBrowserPlugin.plugin), which is only up to version 2.1. Incidentally, this plugin is detected correctly by the plugincheck page.
Comment 4 Robert Kaiser 2012-12-18 13:02:00 PST
Bug 816445 comment #12 says:
This happens with an older DivX browser Plugin. It is still available here:
http://mac.oldapps.com/divx.php?old_divx=1138

I don't have a mac to get the strings, but that's the one we need to be blocking.
Comment 5 Jorge Villalobos [:jorgev] 2012-12-18 13:36:45 PST
Thank you, Kairo. The installer on that site includes version 1.4 of the same plugin, so I'll stage a block for 1.4 and below.
Comment 6 Jorge Villalobos [:jorgev] 2012-12-18 13:49:16 PST
The block is now staged. It should be functional in about an hour:
https://addons-dev.allizom.org/en-US/firefox/blocked/p239

Looping in Laura, in case this has any PR implications.
Comment 7 Virgil Dicu [:virgil] [QA] 2012-12-19 07:34:53 PST
Created attachment 693878 [details]
DivX block UI

Should the UI refer to add-ons and not plugins?
Comment 8 Virgil Dicu [:virgil] [QA] 2012-12-19 07:42:10 PST
The rest looks good.
Verified the block in staging on Mac OS 10.6, 10.7, 10.8.
Divx Web player 1.4.1.4 - blocked on 18 beta, 19 Aurora, 20 Nightly, works on 17 beta
Divx Web player 2.2 - working successfully after the ping on all channels.
Also used the following page to test with: http://sharebees.com/5sbceugdi268

Currently the "More information" link leads to nowhere, but I supposed that will change once the block goes live.
Comment 9 Jorge Villalobos [:jorgev] 2012-12-19 07:44:12 PST
The UI is correct. I forgot to set the severity, so it appeared as a hardblock instead of a softblock, but that's just a minor issue. I corrected the block on staging, but I think we're good to go to push it live.
Comment 10 Scoobidiver (away) 2012-12-19 08:02:44 PST
The request was for the plugin, not the extension.
Are you sure blocking the extension will stop crashes?
Comment 11 Jorge Villalobos [:jorgev] 2012-12-19 08:05:37 PST
The plugin is what's being blocked. The UI says add-ons, but you can see from the icon that it is clearly a plugin being blocked.
Comment 12 Jorge Villalobos [:jorgev] 2012-12-19 13:06:40 PST
Pushed to prod: https://addons.mozilla.org/en-US/firefox/blocked/p240

+SUMO, since they might hear about this.

Note You need to log in before you can comment on or make changes to this bug.