Last Comment Bug 821976 - CSS transition animation fails when parent element changes position attribute
: CSS transition animation fails when parent element changes position attribute
Status: RESOLVED DUPLICATE of bug 625289
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: 17 Branch
: x86_64 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
Depends on: 625289
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-15 01:57 PST by Jakub Chodorowicz
Modified: 2014-08-14 10:41 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fx.transition.parent.position.html (652 bytes, text/html)
2013-09-07 09:41 PDT, Rafał Miłecki
no flags Details

Description Jakub Chodorowicz 2012-12-15 01:57:01 PST
I wanted to change parent node position from static to fixed and at the same time animate some properties of child element using CSS transition. In that situation transition animation fails or even doesn't start.

Here's a jsFiddle example which illustrates this bug.
The hack to fix it is to change CSS attributes in steps: first change position and then after some time (50ms) change rest attributes which need to be animated.

jsFiddle example: http://jsfiddle.net/chodorowicz/bc2YC/10/
StackOverflow thread: http://stackoverflow.com/questions/13880223/css-transition-doesnt-work-in-firefox-when-position-is-changed
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2012-12-15 08:22:51 PST
Looks like a duplicate of one of bug 625289, bug 788677, bug 800927.
Comment 2 Jakub Chodorowicz 2012-12-16 10:47:28 PST
(In reply to Boris Zbarsky (:bz) from comment #1)
> Looks like a duplicate of one of bug 625289, bug 788677, bug 800927.

Yes, it surely is a duplicate of these other 3. Sorry for submitting it again.
Comment 3 Rafał Miłecki 2013-09-07 09:41:01 PDT
Created attachment 801144 [details]
fx.transition.parent.position.html

I just hit the same issue, tracked it down and found this issue. Attaching my minimal test-case (not even using JavaScript).
Comment 4 David Baron :dbaron: ⌚️UTC-10 2014-08-14 10:41:54 PDT
http://jsfiddle.net/chodorowicz/bc2YC/10/ and attachment 801144 [details] fixed in Firefox 34.

*** This bug has been marked as a duplicate of bug 625289 ***

Note You need to log in before you can comment on or make changes to this bug.