Closed Bug 821995 Opened 7 years ago Closed 7 years ago

html5 rendering problem

Categories

(Core :: Layout, defect)

20 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla20
Tracking Status
firefox18 --- unaffected
firefox19 + verified
firefox20 + verified

People

(Reporter: ramsden, Assigned: mattwoodrow)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121214 Firefox/20.0
Build ID: 20121214030827

Steps to reproduce:

load page  http://www.by-art.com/bubbles/
It's a simple game that uses html5 rather than java.


Actual results:

page loads, but the preview of upcoming bubbles is missing.


Expected results:

There should be 2 partially transparent bubbles in the bottom left.  they're missing.
This worked correctly in Nightly 19, and works in the latest version of Google Chrome.
Last good nightly: 2012-12-04
First bad nightly: 2012-12-05

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6fa6e55a93b2&tochange=1942b4d64dc8

I'm now bisecting
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
The first bad revision is:
changeset:   114890:54f08a854e4e
user:        Matt Woodrow <mwoodrow@mozilla.com>
date:        Tue Dec 04 19:04:20 2012 +1300
summary:     Bug 812107 - Don't attempt to do scroll compensation in FrameLayerB
uilder for transformed containers. r=roc
Blocks: 812107
Component: Untriaged → Layout
Product: Firefox → Core
According to the regression range, this is not affecting 19.  Tracking this regression for 20, however.
Upon further read of bug 812107, it was uplifted to FF19.
Assignee: nobody → matt.woodrow
I was offline for a few weeks.  This issue was not in FF19 as of Nov 14.  When I got back and updated to FF20 (Dec 9 or 10) was the first I remember seeing it.
The change that bug 812107 made here was not correct.
Attachment #693241 - Flags: review?(roc)
https://hg.mozilla.org/mozilla-central/rev/607731c891dd
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Can we prepare this change for uplift to FF19 on Beta?
Comment on attachment 693241 [details] [diff] [review]
Revert the transform change

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 812107
User impact if declined: Broken transformed content in some cases.
Testing completed (on m-c, etc.): Been on m-c for a while
Risk to taking this patch (and alternatives if risky): Very low risk, just reverts an earlier change.
String or UUID changes made by this patch: None
Attachment #693241 - Flags: approval-mozilla-beta?
Attachment #693241 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Verified Fixend on Windows 7 x64 using FF 19.b1:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0(20130109111322)
I confirm this fix is verified on Latest Aurora 20 too on Windows 7 x64.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20130129 Firefox/20.0(20130129042016)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.