Closed Bug 822002 Opened 7 years ago Closed 7 years ago

Should not tell Mac OS X Leopard users to buy a new computer

Categories

(support.mozilla.org :: Knowledge Base Articles, task)

All
macOS
task
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: nalimilan, Assigned: verdi)

References

()

Details

As Mac OS X Leopard is no longer a supported OS, Firefox now shows a message and points to a webpage explaining the problem:
http://support.mozilla.org/en-US/kb/firefox-no-longer-works-mac-os-x-10-5

This page states that the best option is to "Switch to a newer computer", as "This is the most secure option and will allow you to run the latest and greatest Firefox.". The possibility to simply upgrade your current computer to a newer version of OS X only comes in second position, and it's presented as an unsecure solution, since Apple may drop support soon.

I think the organization of this webpage should be changed. Telling users they'd better spend $1000 on a new MacBook is rude, in particular when you know they own a not-so-old laptop that can be upgraded for about $20. The day Apple stops providing upgrades for Snow Leopard, they will still be able to install Firefox, and when Firefox drops support for this release, they will still be able to upgrade to Mountain Lion, maybe buying some RAM.

So please present upgrade as the recommended solution. Anyway, you know users are not going to trash their machines, so better give them the real solution. Free software is here to empower people, not stop using their computers. Thanks!
Status: UNCONFIRMED → NEW
Component: Help Documentation → Knowledge Base Articles
Ever confirmed: true
Product: Firefox → support.mozilla.org
Version: 7 Branch → unspecified
Assignee: nobody → mverdi
Thanks for you comments. We don't track article conversations in bugzilla (one day maybe the knowledge base article component will be gone) so I'll close this bug. The conversation for this article is here https://support.mozilla.org/en-US/kb/firefox-no-longer-works-mac-os-x-10-5/discuss/4633
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.