Remove the global PB specific code in tps.jsm from per-window PB builds

RESOLVED FIXED in mozilla61

Status

defect
RESOLVED FIXED
7 years ago
10 months ago

People

(Reporter: Ehsan, Assigned: lina)

Tracking

unspecified
mozilla61

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

We need to make the global PB specific code in http://mxr.mozilla.org/mozilla-central/source/services/sync/tps/extensions/tps/modules/tps.jsm hidden behind #ifndef MOZ_PER_WINDOW_PRIVATE_BROWSING.  One such code is the SetPrivateBrowsing function.  There are three tests which call that function and they should not be run in such builds, but the problem is that they don't use the usual Makefile.in files, and instead they use all_tests.json.  Therefore, we need to also be able to preprocess all_tests.json somehow too, but I'm not sure how to do that.

Richard, do you have any idea?

Thanks!
Component: Firefox Sync: UI → TPS
OS: Mac OS X → All
Product: Mozilla Services → Testing
Hardware: x86 → All
TPS doesn't run on buildbot (yet?), so nothing will go red until services-central has MPWPB set by default. CCing jgriffin, who keeps TPS fed and watered.
TPS runs tests that are bundled into a tests.zip package:

http://mxr.mozilla.org/mozilla-central/source/testing/testsuite-targets.mk#416

We could add some pre-processing here, and add some logic to only copy files that end up in the post-processed version, instead of everything as we do now.
Given comment 1, I'm unblocking this for per-window private browsing, but will leave the bug open since this needs to get fixed when we want to run TPS tests on Tinderbox.
No longer blocks: PBnGen
https://hg.mozilla.org/mozilla-central/rev/418277a17cb2 took care of some of this, but that file is still listening for the private-browsing notification, which will never be dispatched in per-window PB builds.
(In reply to :Ehsan Akhgari from comment #4)
> https://hg.mozilla.org/mozilla-central/rev/418277a17cb2 took care of some of
> this, but that file is still listening for the private-browsing
> notification, which will never be dispatched in per-window PB builds.

That said, there's more mentions of "private-browsing" left in that file...
Josh, I would _really_ like to land this before bug 784841 lands.  gps tells me that will happen next week, if not later this week.
(In reply to :Ehsan Akhgari from comment #6)
> Josh, I would _really_ like to land this before bug 784841 lands.  gps tells
> me that will happen next week, if not later this week.

Wrong bug!
Comment on attachment 8972435 [details]
Bug 822018 - Remove unused mentions of private browsing from TPS.

https://reviewboard.mozilla.org/r/241034/#review246816

LGTM
Attachment #8972435 - Flags: review?(tchiovoloni) → review+
Pushed by kcambridge@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fa4f44996ac6
Remove unused mentions of private browsing from TPS. r=tcsc
https://hg.mozilla.org/mozilla-central/rev/fa4f44996ac6
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Product: Testing → Testing Graveyard
Assignee: nobody → lina
You need to log in before you can comment on or make changes to this bug.