No showing DL meter in win7 taskbar with downloading on private window

RESOLVED FIXED in Firefox 20

Status

()

defect
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: tetsuharu, Assigned: Ehsan)

Tracking

Trunk
Firefox 20
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mentor=jdm][lang=js])

Attachments

(2 attachments)

[Environment]
-http://hg.mozilla.org/mozilla-central/rev/c8a1314aa449

[Step to Reproduce]
Download files on private window.

[Result]
No showing download indicator in windows taskbar.

[more info]
*Is this regression, or by design of per-window private browsing?
*Attached screenshot is DL meter when downloading on normal-window.
Blocks: PBnGen
The relevant code is here: http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/downloads/DownloadTaskbarProgress.jsm

The changes won't be difficult - just make the addListener call addPrivacyAwareListener, and then make the uses of activeDownloads and activeDownloads count extend to cover activePrivateDownloads and activePrivateDownloadCount.
Whiteboard: [mentor=jdm][lang=js]
Posted patch Patch (v1)Splinter Review
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Attachment #694589 - Flags: review?(josh)
Attachment #694589 - Flags: review?(josh) → review+
https://hg.mozilla.org/mozilla-central/rev/3b36ac0574c7
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20
You need to log in before you can comment on or make changes to this bug.