Intermittent Shutdown | application crashed [@ mozalloc_abort(char const*)] due to "ABORT: Tracer synchronization state is wrong: '!sTracerProcessed', file ../../../widget/cocoa/WidgetTraceEvent.mm, line 47"

RESOLVED FIXED in mozilla20

Status

()

--
critical
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: emorley, Unassigned)

Tracking

({assertion, intermittent-failure})

Trunk
mozilla20
x86_64
Mac OS X
assertion, intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Rev4 MacOSX Snow Leopard 10.6 mozilla-central debug test mochitest-browser-chrome on 2012-12-17 06:07:15 PST for push ba26dc1c6267

slave: talos-r4-snow-066

https://tbpl.mozilla.org/php/getParsedLog.php?id=18017025&tree=Firefox

{
--DOCSHELL 0x14e12a1d0 == 6 [id = 267]
WARNING: NS_ENSURE_SUCCESS(rv, false) failed with result 0x8000FFFF: file ../../../../content/base/src/nsContentUtils.cpp, line 2964
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file ../../../../content/xbl/src/nsXBLProtoImplMethod.cpp, line 321
###!!! ABORT: Tracer synchronization state is wrong: '!sTracerProcessed', file ../../../widget/cocoa/WidgetTraceEvent.mm, line 47
mozilla::ShutdownEventTracing() [EventTracer.cpp:195]
XREMain::XRE_main(int, char**, nsXREAppData const*) [nsAppRunner.cpp:3894]
XRE_main [nsAppRunner.cpp:4089]
main [nsBrowserApp.cpp:174]
###!!! ABORT: Tracer synchronization state is wrong: '!sTracerProcessed', file ../../../widget/cocoa/WidgetTraceEvent.mm, line 47
TEST-UNEXPECTED-FAIL | Shutdown | Exited with code 1 during test run
INFO | automation.py | Application ran for: 1:09:00.824614
INFO | automation.py | Reading PID log: /var/folders/Hs/HsDn6a9SG8idoIya6p9mtE+++TI/-Tmp-/tmp93bwVipidlog
PROCESS-CRASH | Shutdown | application crashed [@ mozalloc_abort(char const*)]
Crash dump filename: /var/folders/Hs/HsDn6a9SG8idoIya6p9mtE+++TI/-Tmp-/tmp9MeQJC/minidumps/500633A6-A9DA-46D1-9DA7-101EA6CEBBE6.dmp
Operating system: Mac OS X
                  10.6.8 10K549
CPU: amd64
     family 6 model 23 stepping 10
     2 CPUs

Crash reason:  EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
Crash address: 0x0

Thread 0 (crashed)
 0  libmozalloc.dylib!mozalloc_abort(char const*) [mozalloc_abort.cpp : 23 + 0x0]
    rbx = 0x00007fff70d772f8   r12 = 0x0000000103e6059f
    r13 = 0x0000000103e60579   r14 = 0x00007fff5fbfe240
    r15 = 0x00007fff70d772f8   rip = 0x00000001000d2b64
    rsp = 0x00007fff5fbfe1f0   rbp = 0x00007fff5fbfe200
    Found by: given as instruction pointer in context
 1  XUL!Abort [nsDebugImpl.cpp : 423 + 0x4]
    rbx = 0x00007fff5fbfe230   r12 = 0x0000000103e6059f
    r13 = 0x0000000103e60579   r14 = 0x00007fff5fbfe240
    r15 = 0x00007fff70d772f8   rip = 0x00000001031a6819
    rsp = 0x00007fff5fbfe210   rbp = 0x00007fff5fbfe210
    Found by: call frame info
 2  XUL!NS_DebugBreak_P [nsDebugImpl.cpp : 380 + 0x7]
    rbx = 0x00007fff5fbfe230   r12 = 0x0000000103e6059f
    r13 = 0x0000000103e60579   r14 = 0x00007fff5fbfe240
    r15 = 0x00007fff70d772f8   rip = 0x00000001031a65b9
    rsp = 0x00007fff5fbfe220   rbp = 0x00007fff5fbfe660
    Found by: call frame info
 3  XUL!mozilla::SignalTracerThread() [WidgetTraceEvent.mm : 47 + 0x24]
    rbx = 0x0000000100119200   r12 = 0x0000000000000000
    r13 = 0x00007fff5fbfe710   r14 = 0x00007fff5fbfe710
    r15 = 0x0000000100003230   rip = 0x0000000102d970b0
    rsp = 0x00007fff5fbfe670   rbp = 0x00007fff5fbfe690
    Found by: call frame info
 4  XUL!mozilla::ShutdownEventTracing() [EventTracer.cpp : 193 + 0x4]
    rbx = 0x0000000100119200   r12 = 0x0000000000000000
    r13 = 0x00007fff5fbfe710   r14 = 0x00007fff5fbfe710
    r15 = 0x0000000100003230   rip = 0x0000000101818c9a
    rsp = 0x00007fff5fbfe6a0   rbp = 0x00007fff5fbfe6a0
    Found by: call frame info
 5  XUL!XREMain::XRE_main(int, char**, nsXREAppData const*) [nsAppRunner.cpp : 3894 + 0x4]
    rbx = 0x0000000100119200   r12 = 0x0000000000000000
    r13 = 0x00007fff5fbfe710   r14 = 0x00007fff5fbfe710
    r15 = 0x0000000100003230   rip = 0x000000010180c638
    rsp = 0x00007fff5fbfe6b0   rbp = 0x00007fff5fbfe6f0
    Found by: call frame info
 6  XUL!XRE_main [nsAppRunner.cpp : 4089 + 0x14]
    rbx = 0x00007fff5fbfe7c0   r12 = 0x0000000000000006
    r13 = 0x00007fff5fbfe710   r14 = 0x00007fff5fbfe820
}
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Ted, this regressed very recently, any ideas who may have caused it?
Flags: needinfo?(ted)
Comment hidden (Treeherder Robot)
Were there any browser-chrome tests added recently that turn on the profiler? I saw a devtools blog post about profiler UI, that's probably the root cause. We should probably just land the reviewed patch over on bug 766883 to make this go away.
Flags: needinfo?(ted)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Should be fixed by bug 766883.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
You need to log in before you can comment on or make changes to this bug.