Closed Bug 822400 Opened 7 years ago Closed 7 years ago

Please modify blocklists for CTP (includes FF17 on release)

Categories

(Toolkit :: Blocklist Policy Requests, defect)

defect
Not set

Tracking

()

VERIFIED FIXED

People

(Reporter: akeybl, Assigned: jorgev)

Details

Now that we've gotten good uptake on FF17 (thus mitigating bug 812927), we can move forward with the planned CTP blocklists. The following changes are being requested based upon https://etherpad.mozilla.org/plugin-blocks

Java:
* [CTP][All] Java 6 U33 - Java 6 U36. Firefox 18.0a1 and above.
** Move to Firefox 17 and up
* [CTP][All] Java 7 U7 - Java 7 U8. Firefox 18.0a1 and above.
** Move to Firefox 17 and up

Silverlight:
* [p152][Infobar][Windows] Versions 0 - 4.1.10328.0. Firefox 16.* and below.
** Move to all versions of Firefox
* [p154][Infobar][Windows] Versions 5.0 - 5.1.10410.0. Firefox 16.* and below.
** Move to all versions of Firefox

Adobe Reader:
* [p156][Infobar][Windows] Versions 0 - 9.5.1. Firefox 16.* and below.
** Move to Firefox 17 and up
* [p158][Infobar][Windows] Versions 10.0 - 10.1.3. Firefox 16.* and below.
** Move to Firefox 17 and up

All of the above blocklists are currently in testing in FF18, and have been previously tested with FF17.

This will basically amount to:
* All non-current versions of Silverlight will now be CTP blocklisted on Windows for Firefox 17 and up
* All non-current versions of Adobe Reader will now be CTP blocklisted on Windows for Firefox 17 and up
* Recent versions of Java (other than current) that have not already been softblocked will now be CTP blocklisted on all platforms

The goal is to push to production Tuesday, given our prior testing.
Summary: Please modify blocklists for CTP → Please modify blocklists for CTP (includes FF17 on release)
Even though we have previous testing, I'd like the opportunity spotcheck each of these once they've been updated for the new versions. Please don't push this to production without any further testing. Thank you.
All changes have been staged as specified. Please give the cache at least an hour to reload.

(In reply to Alex Keybl [:akeybl] from comment #0)
> Adobe Reader:
> * [p156][Infobar][Windows] Versions 0 - 9.5.1. Firefox 16.* and below.
> ** Move to Firefox 17 and up
> * [p158][Infobar][Windows] Versions 10.0 - 10.1.3. Firefox 16.* and below.
> ** Move to Firefox 17 and up

This means we won't have the infobar block anymore for 16 and below, correct?
Keywords: qawanted
(In reply to Jorge Villalobos [:jorgev] from comment #2)
> All changes have been staged as specified. Please give the cache at least an
> hour to reload.
> 
> (In reply to Alex Keybl [:akeybl] from comment #0)
> > Adobe Reader:
> > * [p156][Infobar][Windows] Versions 0 - 9.5.1. Firefox 16.* and below.
> > ** Move to Firefox 17 and up
> > * [p158][Infobar][Windows] Versions 10.0 - 10.1.3. Firefox 16.* and below.
> > ** Move to Firefox 17 and up
> 
> This means we won't have the infobar block anymore for 16 and below, correct?

Sorry, we can do this for all Firefox versions.
Just to clarify, Firefox 17 and above will receive a CTP block, 16 and below will receive an infobar block (because CTP does not exist before Fx17). Is this correct?
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #4)
> Just to clarify, Firefox 17 and above will receive a CTP block, 16 and below
> will receive an infobar block (because CTP does not exist before Fx17). Is
> this correct?

Yes, that will be the case for all blocks on this bug that support anything below 17.
(In reply to Alex Keybl [:akeybl] from comment #3)
> (In reply to Jorge Villalobos [:jorgev] from comment #2)
> > This means we won't have the infobar block anymore for 16 and below, correct?
> 
> Sorry, we can do this for all Firefox versions.

I updated the Adobe blocks so they apply to all Firefox versions.
Results from Staging...

CTP Blocked:
* Java 6u33 + Fx17.0.1: PASS
* Java 7u7 + Fx17.0: PASS

Infobar Blocked:
* Silverlight 5.0.61118 + Fx15.0.1: PASS
* Silverlight 4.0.60531 + Fx14.0.1: PASS

* Reader 9.3.4 + Fx14.0.1: PASS 
* Reader 10.0.1 + Fx15.0: PASS

Seems to be working as expected. We can push this at Alex's convenience.
Keywords: qawanted
Let's push these blocks out whenever you all get the chance. Thanks for the quick turnaround.
This is now live.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Results from Production...
* Java 6u33 + Fx17.0.1: CTP blocked
* Java 7u7 + Fx17.0: CTP blocked

* Silverlight 5.0.61118 + Fx15.0.1: Infobar blocked
* Silverlight 4.0.60531 + Fx14.0.1: Infobar blocked

* Reader 9.3.4 + Fx14.0.1: Infobar blocked 
* Reader 10.0.1 + Fx15.0: Infobar blocked
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → Toolkit
You need to log in before you can comment on or make changes to this bug.