Closed Bug 822421 Opened 7 years ago Closed 7 years ago

about:home text illegible on dark Lightweight themes

Categories

(Firefox for Android :: Theme and Visual Design, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 20
Tracking Status
firefox19 --- verified
firefox20 --- verified

People

(Reporter: sriram, Assigned: sriram)

References

Details

Attachments

(1 file)

On dark themes, the text color on about:home is barely readable.
Attached patch PatchSplinter Review
This fixes the problem as the UX suggested colors.
Attachment #693065 - Flags: review?(mark.finkle)
Blocks: themes
Comment on attachment 693065 [details] [diff] [review]
Patch

Part of me is not happy we need to add so much code. But I guess we need this.
Attachment #693065 - Flags: review?(mark.finkle) → review+
Assignee: nobody → sriram
I had triggered a clobber for the same. It's a clobbering issue.
https://hg.mozilla.org/mozilla-central/rev/65b79c7b4105
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20
Comment on attachment 693065 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Personas
User impact if declined: about:home text is illegible when dark themes are applied. So users cannot sport a Darth Vader theme for Firefox!
Testing completed (on m-c, etc.): Landed on m-c yesterday.
Risk to taking this patch (and alternatives if risky): Very low. Proven concept of state-list that we use everywhere.
String or UUID changes made by this patch: None.
Attachment #693065 - Flags: approval-mozilla-aurora?
Comment on attachment 693065 [details] [diff] [review]
Patch

Approving for aurora given the low risk profile here.
Attachment #693065 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/file/tip/mobile/android/base/GeckoView.java.frag
This particular file is needed for this patch to land -- which is currently not available in Aurora. Do I add a trimmed down version of the file as a separate patch for Aurora -- which will be like a pre-requisite for this patch?
(In reply to Sriram Ramasubramanian [:sriram] from comment #11)
> https://hg.mozilla.org/mozilla-central/file/tip/mobile/android/base/
> GeckoView.java.frag
> This particular file is needed for this patch to land -- which is currently
> not available in Aurora. Do I add a trimmed down version of the file as a
> separate patch for Aurora -- which will be like a pre-requisite for this
> patch?

The preferred approach would be to create a new version of this patch that does not depend on GeckoView.java.frag changes. We like to avoid pulling in additional changes to aurora if they are not really needed.
Firefox 20.0a1 (2013-01-02)
Device: Galaxy Nexus 
OS: Android 4.1.1 

The text in about:home is not visible (is now white as the wordmark). Verified Fixed for Nightly 20.0a1

Please push it to Aurora too so we close this bug verified for all branches.
Firefox 19 Beta 1 (2013-01-08)
Device: Galaxy Nexus
OS:Android 4.1.

This was push in beta channel also as Firefox 19 is currently in Beta. As the text is white now I will mark the bug Verified Fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.